Ask / Submit
11

3.5mm Audio Connector not working on XA2

Tracked by Jolla (In progress)

asked 2019-01-22 13:28:21 +0200

tomas3000 gravatar image

updated 2019-01-25 22:44:08 +0200

deloptes gravatar image

I am not sure if it is because of 3.0.1 or a problem of the device XA2 itself. I did not have tested it before on Android...

But when I insert now my headphones connector, they are not recognised by the phone. Not while playing music and not while calling.

Anybodz has the same problem or even a solution?

edit retag flag offensive close delete

Comments

1

Hey Same here with my Xperia X, since 2.8 update. Still not working with 3.0.1. To be able to use a headset, i bought a (very cheap) DAC and by the miracle of USB OTG, it works. Almost: it works with music, but it is not known when passing calls. And doesn't ring (ring is only on the loudspeaker).

Would love to be able to use my headset when passing calls !

Chap ( 2019-01-25 16:20:56 +0200 )edit
1

Similar problem on Sailfish X and it is reproducible. It actually started on previous Sailfish X 2 - I was thinking first the audio jack is broken. In the meanwhile I upgraded to X3 but it was still not working. Only few days ago I wanted to see something in youtube - which I usually do not use on the phone. I noticed there is no sound, which was strange. After rebooting sound was there. I checked with headphone and it worked.

Few days later I wanted to use HERE. After I finished, sound was missing again. After 2nd reboot it worked.

I will check solution by @tanakian and report/edit here if it works.

deloptes ( 2019-01-25 21:01:15 +0200 )edit

5 Answers

Sort by » oldest newest most voted
6

answered 2019-01-22 13:55:32 +0200

jiit gravatar image

updated 2019-01-22 13:58:30 +0200

This is now reported, thank you. Meanwhile could you try with another wired headset as well? If the headphones are detected as lineout, we don't support it at the moment; but it's known issue and will be fixed at some point.

edit flag offensive delete publish link more

Comments

Tested my Xperia XA2 (latest update 3.0.1.11) right now together with the headphones that came with my Lumia 950. Sound is there, controls (play, pause, skipping forward and backwards) also work as expected. I just wondered that if I skip while playback is paused the phone continues playing, while on other systems playback stays paused after skipping.

Cryx ( 2019-01-22 14:17:16 +0200 )edit

I tested the same headphones with Jolla 1 (also on 3.0.1.11) and they are also not working. But they are working on an Android phone. Unfortunately I do not have other headphones here...

tomas3000 ( 2019-01-22 14:27:30 +0200 )edit

I tested with different headphones today and they worked on Jollas (XA2 and J1) as well as on Android. So it seems like there are only some special headphones which only work on Android and not on Jolla. They seem to be very basic, there is not even a company name printed on them. Only maybe relevant thing: One of the earspeakers is broken (maybe the cord to the earspeaker)?

tomas3000 ( 2019-01-23 09:14:38 +0200 )edit
1

I have the same problem with XA2. All my headphones work but line out cables to speakers/amplifiers do not. Unfortunately I did not test it with Android before flashing. Edit: Just read through the whole answer, that line out is a known problem..

speactra ( 2019-01-23 10:58:54 +0200 )edit
3

answered 2019-02-12 22:45:39 +0200

TCJ gravatar image

Hello Sailors!

I've done a little more digging and have found a more permanent solution to this headphone problem. It looks like a particular module, module-switch-on-port-available, is not loaded by the Pulse Audio (PA) server on start-up. This particular module enables the port switching ability inside the PA server when a headphone is attached or detached.

I'm using a Sony Xperia XA2 with SFOS 3.0.1.14. So far it is working with my test headset (Plantronics Blackwire 300 DA), YMMV though.

I've enabled Developer Mode on my phone. You'll need to be root to edit some of these files. Open up the Terminal application (or connect remotely) to perform the following:

Find which config file PA is reading on startup

[nemo@Sailfish ~]$ cat /etc/sysconfig/pulseaudio
CONFIG="-n --file=/etc/pulse/arm_droid_default.pa"

Switch to root, so we can edit /etc/pulse/arm_droid_default.pa (Note: Password is the one set when enabling Remote Connection in the Developer Tools menu under Settings)

[nemo@Sailfish ~]$ devel-su
Password:
[root@Sailfish nemo]#

Use your editor of choice to add the following line to the end of /etc/pulse/arm_droid_default.pa

### module to enable sensing of headphone jack
load-module module-switch-on-port-available

Now, reboot your phone

[root@Sailfish nemo]# reboot

After the phone has rebooted, open the Terminal app (or connect remotely) to check that the module has loaded properly.

[nemo@Sailfish ~]$ pactl list short modules | grep switch
25      module-switch-on-port-available
[nemo@Sailfish ~]$

The module-switch-on-port-available module has been loaded (remove the grep command to see all the loaded PA modules), hopefully allowing you to use your headset jack with minimal fuss.

Hope this helps!

TCJ

edit flag offensive delete publish link more

Comments

Tested on a mic+headphone (trrs) that sometimes was picked up and sometimes wasn't. With fix, it works everytime. Although, it does not help connecting to amp or car fm (both trs).

Sé Zuo ( 2019-02-13 18:58:08 +0200 )edit
2

answered 2019-01-23 17:43:19 +0200

tanakian gravatar image

this solves my problem:

pacmd list-sinks

to get list of outputs

then

pacmd set-sink-port sink.primary_output output-wired_headphone

routes audio via jack, and

pacmd set-sink-port sink.primary_output output-line

also routes audio via jack, but the volume is a bit lower.

i guess this is a correct setting.

pacmd set-sink-port sink.primary_output output-speaker

routes back to speaker.

found it by following hints of someone helpful from telegram sailfish chat.

edit flag offensive delete publish link more

Comments

Thank you for your solution. But in order to be able to use it, can you explain the previous steps ? IE: Developer mode ? console ? and then the command pacmd list-sinks ?

Thank you for your help.

Chap ( 2019-01-25 16:25:38 +0200 )edit

I tried today. It told me :

No sink found by this name or index
deloptes ( 2019-01-26 23:36:58 +0200 )edit
1

answered 2019-01-27 00:15:43 +0200

deloptes gravatar image

updated 2019-01-27 00:16:02 +0200

on Xperia X 3.0.1.11 following works. (saved in two files, made executable)

 pacmd set-sink-port sink.primary output-speaker

 pacmd set-sink-port sink.primary output-wired_headphone

based on @tanakian answer

edit flag offensive delete publish link more

Comments

I wish we could have a switch - the headphone option gives even better sound quality (might be because phones have high ohm/resistance) in my wifes car audio.

I saw recently there is PA manager for Qt in KDE ... can this be somehow ported?

deloptes ( 2019-01-29 10:20:49 +0200 )edit

The above suggestion by deloptes works, but on 3.0.1.14, change sink.primary to sink.primary_output as suggested previously by tanakian

TCJ ( 2019-02-12 20:53:34 +0200 )edit
0

answered 2019-01-23 13:19:50 +0200

tanakian gravatar image

there should be some way to tell sailfish to recognize it in different way, right? by writing something to /proc or /sys files?

edit flag offensive delete publish link more

Comments

There is a sense key in the female and it is working. I think the problem is within pulseaudio (PA). I heard PA got rid of many bugs in 12.2 and asked for someone to compile, but nothing happened and we got some patched version of 11.1 (AFAIR).

deloptes ( 2019-01-25 22:25:40 +0200 )edit
Login/Signup to Answer

Question tools

Follow
10 followers

Stats

Asked: 2019-01-22 13:28:21 +0200

Seen: 832 times

Last updated: Feb 12