Ask / Submit
17

Garbled playback of some mp3s with builtin player [released]

asked 2014-02-03 08:59:39 +0200

thebat137 gravatar image

updated 2014-07-24 10:52:08 +0200

jiit gravatar image

I like to listen to mp3 podcasts with my phone, but I have discovered that when I use the built in media player, the playback of certain podcasts seems to become garbled after a minute or so, with the audio jumping back and forth between different bits of the file, and sometimes the sound quality becomes warbly and echoey. Skipping to a different time in the podcast can cause the playback to temporarily return to normal, but then it deteriorates again. All of the problematic mp3s work fine from my laptop (running Debian unstable).

I've linked to a few examples below of podcasts that have problems:

And here is one which does not have problems:

If one episode of a particular podcast is problematic, it seems that all, or at least many, of them are, so I'm assuming it's something about the particular encoding parameters that causes trouble. Any thoughts?

edit retag flag offensive reopen delete

The question has been closed for the following reason "released in a software update" by sjn
close date 2015-09-14 01:45:54.784596

Comments

2

I tried the The Thinking Atheist one, started skipping like 10 seconds in. It's a 8000 Hz sample rate, mono file with a bitrate of 32 kbps which I suppose is sort of exotic compared to your average music file.

ZZB ( 2014-02-03 09:14:37 +0200 )edit

I am getting very similar behaviour on some of my MP3 files as well.

Axel ( 2014-03-05 16:48:05 +0200 )edit

I also have mp3s with sample rate 11025 Hz, which suffer from same problem.

As a test I tried recoding them to ogg (with same sample rate), but those ogg files were similarly garbled. However recoding files as a mp3 with sample rate 44100Hz seems to fix the problem, so it seems that trouble is caused by sample rate.

Also as both mp3 and ogg were affected, the problem is probably not at the codec, but rather somewhere further at the playback. (pulse audio?)

JPS ( 2014-03-24 22:52:18 +0200 )edit

4 Answers

Sort by » oldest newest most voted
7

answered 2015-05-31 02:05:05 +0200

MSameer gravatar image

updated 2015-05-31 15:06:34 +0200

I would like to apologize first for the lack of a public gst-av repository.

It seems it was dropped by mistake when we pushed all our GStreamer bits to github.

I have created a github repository underneath sailfishos project and pushed the git history to it. You can find it here: https://github.com/sailfishos/gst-av and that repository is what will be used for any farther development. The internal repository is now abandoned.

I also merged in the patch from this PR https://github.com/felipec/gst-av/pull/3 so it should be released in a future update (I cannot tell when exactly).

Thanks to @thp for making me aware of this issue and submitting the PR to our internal repository.

edit flag offensive delete publish link more

Comments

1

I still have problems playing low-bitrate mp3 (with Björnträsket 1.1.7.25). I see the changelog mentions gst-libav, but not gst-av, so I'm wondering:

Was this fix not included in the Björntäsket release? :-(

sjn ( 2015-07-30 20:54:19 +0200 )edit

I have no idea what happened. It could be that something went wrong. I could investigate if needed but I have made sure this issue got fixed with the new GStreamer 1.x stack which I am confident - but cannot promise - will be released in the next update.

MSameer ( 2015-08-10 13:00:55 +0200 )edit
6

answered 2014-08-19 03:23:58 +0200

keithzg gravatar image

updated 2014-09-27 02:07:56 +0200

Tested and encoding to WAVE it plays back fine:

avconv -i bill-nye-and-the-creationist-guy.mp3 bill.wav

However, do the same with FLAC: avconv -i bill-nye-and-the-creationist-guy.mp3 bill.flac, Vorbis in OGG: avconv -i bill-nye-and-the-creationist-guy.mp3 -acodec libvorbis bill.ogg, or FLAC in OGG: avconv -i bill-nye-and-the-creationist-guy.mp3 bill.ogg, and it still glitches.

Launched via gst-launch-0.10 -v playbin uri=file:/home/nemo/Downloads/bill.wav, btw (thanks, javispedro!). During skips, I see output like:

[mp3 @ 0x421b7360] overread, skip -9 enddists: -5 -5

Among the more recent (and higher quality) files that I've run into with this problem is http://traffic.libsyn.com/wtfpod/WTF_-_REMEMBERING_ROBIN_WILLIAMS.mp3, which appears to take longer to start skipping than the Thinking Atheist episode. The WTF episode is 22050Hz, while the Thinking Atheist episode is only 8000Hz; both are mono.

Edit: Note that this happens with both the "Media" app and with gPodder.

Edit 2: Thanks again to javispedro, it seems rather clear that the problem stems somehow from the gst-av plugin, specifically https://github.com/felipec/gst-av/blob/master/gstav_adec.c#L168 which is an accidental implicit cast (should read "uint64_t" instead of "uint32_t").

edit flag offensive delete publish link more

Comments

There is a fix in this link, apparently. https://together.jolla.com/question/30533/mediaplayer-fails-with-low-samplerates/

Regards

Edz ( 2014-09-27 00:28:20 +0200 )edit
4

The gst-av codebase looks almost abandoned. Perhaps someone at Jolla could offer to take over the project in order to do a new release?

Alternatively, since the RPM is packaged by Jolla, the could apply the patch downstream (with themselves) util the upstream issues/ownership/tuits have been resolved?

sjn ( 2015-03-20 01:34:54 +0200 )edit

I've tried mailing the author. Let's see if this makes a difference. :)

sjn ( 2015-03-20 02:05:10 +0200 )edit
6

answered 2015-05-30 12:10:37 +0200

thp gravatar image

Thanks for the patch at https://github.com/felipec/gst-av/pull/3, I've forwarded it to the internal gst-av repo (and asked whether we can put it into some public Git repo, instead of only distributing source tarballs with releases).

edit flag offensive delete publish link more

Comments

5

Thanks, Thomas.

  • Believe me, this is very much appreciated. There's a lot of audio out there (podcasts only being a part of it) that has been unavailable to us Jolla users, just because of this bug. At times, it's been annoying as hell. I think I won't go too far by saying that there are a lot of us out there that appreciate what you're doing.

  • BUT. Feel also free to point out to your colleagues/co-hackers/collaborators that having an authoritative public source code repository isn't really a "nice to have" for an open source project any more.

  • Today, I'd even go as far as saying that if you are not publishing your changes directly to a publicly announced souce code repository, you're doing Open Source WRONG.

  • Feel free to direct your colleagues to this post. I'll gladly play the "annoyed customer" role in public, if it means you guys (the Jolla devs) can get your Open Source act together.

</annoyed>

sjn ( 2015-05-30 15:17:36 +0200 )edit
3

I'll cosign sjn's comments. The lack of a publicly announced repository with formal, closely-managed, bug-reporting and patch-submission mechanisms accessible to the wider user/developer community makes the whole process feel very opaque and user-hostile. I really love my phone, and I know the Jolla folks are working very hard to improve them, but the current status quo makes it feel like bug reports posted here, and solutions offered by users, aren't even being acknowledged, much less made use of. IMO, this defeats the whole point of open source.

thebat137 ( 2015-05-30 19:36:28 +0200 )edit
1

The source repository is now published here: https://github.com/sailfishos/gst-av/

thp ( 2015-06-12 12:23:26 +0200 )edit
3

answered 2015-09-14 01:45:10 +0200

sjn gravatar image

I can now confirm that this issue has been resolved in SailfishOS 1.1.9.28! \o/

edit flag offensive delete publish link more

Comments

Really excellent result and does improve the usability of the phone immensely.

richardski ( 2015-09-14 10:22:28 +0200 )edit

I apologize for all the issues associated with fixing this bug. Glad it worked at the end \o/

MSameer ( 2015-09-14 15:05:57 +0200 )edit

Yes, this really makes the media application usable for podcasts and audiobooks. Thank you for finally making this work! Now we only need a way to browse big audio collections with ease.

mikelima ( 2015-09-14 15:46:37 +0200 )edit

Question tools

Follow
7 followers

Stats

Asked: 2014-02-03 08:59:39 +0200

Seen: 901 times

Last updated: Sep 14 '15