Ask / Submit
24

bug: jolla lost all phone numbers

asked 2014-02-21 19:11:08 +0200

Macilaci457 gravatar image

updated 2014-08-13 10:20:35 +0200

jiit gravatar image

Today, I wanted to make a call, but there were no phone contacts in my Jolla.

There were people in, but not all of them, and there were no phone number for the name. I still do not know how to get the numbers back.

Google DO sync to my phone, but only email addresses, etc. , but no phone numbers. People app has some people, but in phone, the call contact menu is empty because simply no phone numbers in my phone.

edit retag flag offensive close delete

Comments

1

Just deleted Google Account, which removed the last remained contacts from my phone. Added it again, and only those were synced without phone numbers. Only e-mail addresses. Something wrong with sync.

Macilaci457 ( 2014-02-21 19:44:03 +0200 )edit

Maybe something got corrupt in your contacts database, for whatever reason... are you fine with using the developer mode? Then you could try to delete the database files as described here: https://together.jolla.com/question/21224/contacts-list-broken-contactsd-cpu-load-cannot-proceed-with-invalid-self-contact/?answer=21252#post-id-21252 (the problem was another, but doing this might help with yours, too)

tokaru ( 2014-02-21 19:47:50 +0200 )edit

No, I do not want to use developer mode. What I did is to completly remove google account, which removed the contacts. Then added again. So the database file could have rewritten. I do not know. But the synced contacts are still without phone contacts.

Macilaci457 ( 2014-02-21 19:51:08 +0200 )edit

Also checked in google web, phone numbers are there.

Macilaci457 ( 2014-02-21 19:52:04 +0200 )edit

Same thing happened to me last night. Couldn't get it to sync, in the end had to transfer my contacts from my secondary device.

hoenik ( 2014-02-21 20:41:26 +0200 )edit

4 Answers

Sort by » oldest newest most voted
12

answered 2014-02-26 03:55:37 +0200

chris.adams gravatar image

updated 2014-02-26 11:56:36 +0200

This is due to two unfortunate bugs which have now been fixed.

The first was that we had set up our application permissions wrongly, and Google recently started enforcing their permissions model more strictly, which meant that our sync adapter hit authorisation errors. The second was that when that occurred, the sync adapter code assumed that the account was invalid, and removed previously-synced contact data from the device.

The first bug has now been fixed via our Google application console, which means if you delete your Google account, wait a couple of minutes, and then re-add your Google account, you should get your contact data again. (You can use systemctl --user stop msyncd.service; SOCIALD_LOGGING_LEVEL=3 devel-su -p msyncd to get more information from the sync adapter on device, in case you hit issues - email me the log at chris dot adams at jolla dot com - thanks!)

The second bug has been fixed in our device software and will be released via update in the near future.

This sort of bug has a drastic effect on the usability of the device for its primary purpose, and I realise that it's inexcusable that this occurred. I'd personally like to thank all of our amazing community members who sent me logs which helped us to track down the root cause of the issues - much appreciated.

Cheers,

Chris.

/edit: important update: it turns out that we still have a problem with our application permissions, which means that after resigning in, the AccessToken will be invalidated within approximately an hour. We are looking into this again.

/edit: should be fixed now.

edit flag offensive delete publish link more

Comments

It just happened to me a couple of minutes ago.

Disabled the account -> save Enabled the account -> save

And the sync works again.

If I delete the account, and re-add it. My call log is deleted for some reason.

arnbak ( 2014-02-26 09:09:31 +0200 )edit

@arnbak - so you're saying that it better to disable/enable the account than delete/add it ?

idiallo ( 2014-02-26 10:17:28 +0200 )edit

@idiallo - I find it annoying that I lose my call logs by deleting the google account - so for me its better to disable and enable the account to get the sync working again.

arnbak ( 2014-02-26 10:49:34 +0200 )edit

Ok, it worked at last: I removed the Google account, waited 15 min. Added again the Google account. The contacts appeared about 3 hours later (without reboot).

Jordi ( 2014-02-26 13:38:02 +0200 )edit

How about using one way sync for contacts? Jolla should never touch this kind of data unless explicitly asked by user.

strayobject ( 2014-02-26 16:47:12 +0200 )edit
2

answered 2014-02-26 11:09:46 +0200

KylliOrvokki gravatar image

updated 2014-02-26 11:12:27 +0200

Previous answers did not work for me but this did.

Workaround:

  1. Disable google account (settings - accounts)
  2. Restart phone
  3. Enable google account

  4. Enjoy your contacts

edit flag offensive delete publish link more

Comments

Works here, without restarting the phone.

arnbak ( 2014-02-26 12:13:53 +0200 )edit

Nice. I needed restart as well. For me it did not work without it.

KylliOrvokki ( 2014-02-26 12:41:05 +0200 )edit
1

answered 2014-02-22 09:06:54 +0200

Jordi gravatar image

updated 2014-02-26 00:00:26 +0200

To force the sync, go to Settings, Accounts, choose the one you want to sync (Google for ex.), wait 2 seconds until you see "Save" in the top right corner and press it.

Edit Feb 25 '14: This morning, I had the problem once again and this did not help. Weird. I also removed the account and entered it again, still nothing.

The calendar is synced normally, though.

edit flag offensive delete publish link more

Comments

well, that did not solve it. Still no phone numbers.

Macilaci457 ( 2014-02-22 09:39:00 +0200 )edit
1

answered 2014-02-22 12:38:19 +0200

Mikko Koskelin gravatar image

updated 2014-02-22 12:39:58 +0200

I got this solved. Forcing re-sync didn't work. What I did: Go to: Settings -> Accounts -> choose google account. Choose "update login info" from the pulley menu. (My phone is in Finnish so translation might be a bit off) Login with google account, jolla asks for permission to use google. Click accept from the bottom of the page. Then wait for couple seconds and press save (top right corner).

Hope this works for you too.

edit flag offensive delete publish link more

Comments

Tried that too... My Jolla do syncs with google. But not the phone numbers.

Macilaci457 ( 2014-02-22 14:30:03 +0200 )edit
1

I was using Mitakuuluu, and i opened recent calls, and there was only numbers showing, No names. Then i checked my phonebook, there was some names, not all of them, without any numbers. And same time i got notification about a new update, 1.0.3.8. I tried to reboot my phone, but same mess was there. I deleted my google account and add it again. I get my old contacts back, but without any linkages.

Nitro ( 2014-02-23 16:12:24 +0200 )edit
Login/Signup to Answer

Question tools

Follow
12 followers

Stats

Asked: 2014-02-21 19:11:08 +0200

Seen: 919 times

Last updated: Feb 26 '14