Ask / Submit
34

Mobile Data switcher grey out

asked 2014-07-18 12:41:37 +0200

Igorion gravatar image

updated 2015-02-18 17:00:44 +0200

Jarno gravatar image

I can't turn on Mobile Data, because switcher in settings grey out and unselectable. Restart connman, ofono services, reboot phone didn't helped. What else I can try to do?

edit retag flag offensive close delete

12 Answers

Sort by » oldest newest most voted
14

answered 2014-12-21 17:30:36 +0200

Hubb5 gravatar image

updated 2015-03-03 19:46:20 +0200

Hi, I have a similar issue after update 1.1.1.27: I can turn on Mobile Data but when I turn it off the icon becomes gray and I must restart the phone or restart ofono service to make the connection work again.

I look in /var/lib/ofono/ wehre there are four directory: 208...62/ ; 208...62-3/ ; 222...39/ ; 222...39-2/. The two directories ending with -number are empty. The other two contain both a gprs file: one for my actual operator (Wind, Italian) and one for an old sim (Free, French).

Because I think the problem cames from these two different configurations, I would ask if can I simply delete the directory of the old operator or if is there a way to reset the network configuration without a complete phone reset.

Thank you :)

Edit: I deleted all the folders and restarted the phone. A new 222...39 folder appeared with correct configuration files but the problem is still there. I also noted that the icon becomes again normal after some time (first time after about 4 hours and a second time after about 11 hours).

Do you have other suggestions?

EDIT(03/03/2015): Update 1.1.2.16 fixes the problem for me

edit flag offensive delete publish link more

Comments

1

You can delete them, but, make a backup of these two folders just in case :-) After that, dont forget to restart the ofono daemon.

ced117 ( 2014-12-21 18:52:36 +0200 )edit
1

I have experienced exactly the same issue with the same software version. restarting the phone seems to be the only fix that works for me.

willemlaurentz ( 2014-12-22 22:26:51 +0200 )edit
2

Enabling and disabling Flight mode seems to make the icon active again. That doesn't solve the problem but this way is faster than rebooting the phone.

Hubb5 ( 2014-12-23 15:22:41 +0200 )edit
2

Same problem since 1.1.1.26 / 27 . Italy, Wind operator

Luca ( 2014-12-23 16:05:02 +0200 )edit
1

for me it also happend after upade 10 .... Before I was using mobile data mode without any problems. Let's call it clear :) IT's A BUG.

tuniek ( 2014-12-23 17:45:43 +0200 )edit
12

answered 2014-07-18 15:44:44 +0200

zlatko gravatar image

updated 2014-07-27 09:53:27 +0200

I have had similar issue. "Mobile data" greyed out and not accessible.

Here is how I solved it in my case:

  1. When I checked /var/lib/ofono/operator_number/grps - I found out AccessPointName was missing.

  2. I stopped ofono with systemctl stop ofono.service

  3. Edited gprs file adding APN

  4. Started ofono: systemctl start ofono.service

edit flag offensive delete publish link more

Comments

Brilliant it worked, thanks!

flywheel ( 2014-07-18 16:24:15 +0200 )edit

Yes, i solved it too. Thanks.

Igorion ( 2014-07-19 10:25:25 +0200 )edit

I have the same issue, it's a bug of that release.
If miss the AccessPointName is impossible to set it by UI

muchasuerte ( 2014-09-04 01:22:13 +0200 )edit

@zlatko

@flywheel

@Igorion

@muchasuerte

Could you clarify if the "Internet" row of your Mobile data settings was greyed out AND you couldn't long tap&edit it? Or was it completely missing, meaning the next thing under Mobile data was the Data roaming setting?

Obviously AccessPointName should never be missing, I wonder what could have poked the file around.

tkenakka ( 2014-09-24 09:34:14 +0200 )edit

@tkenakka In my case Mobile data settings row was greyed out and long pressing it was doing nothing.

zlatko ( 2014-09-24 10:17:09 +0200 )edit
6

answered 2016-12-01 15:58:14 +0200

hullabaluh gravatar image

Hello all In my case it was the error that in the ril file in /var/lib/ofono/ still the configuration settings for my old sim card (I recently changed provider) were noted. So I had to stop the ofono.service, edit the file /var/lib/ofono/ril to point to the correct configuration folder and restart the service. That was it.

edit flag offensive delete publish link more

Comments

I had the exact same problem, and this solved it. Inputing the correct APN details through the normal settings had no effect, and the mobile data icon stayed greyed out, even after restarting and replacing the card. I don't know if it's related, but both SIM cards used the same network, in my case NTT DOCOMO, in Japan.

K-Nick ( 2016-12-12 11:53:25 +0200 )edit

hi, I just bought the intex aquafish, and internet mobile data does not work, it keeps grey out. I do not kwon what to do. My provider is Movistar from spain. Can you help me with that? I already edited the APN and everything seemed correct. Do not know what to do next

thanks

rai ( 2016-12-16 22:06:52 +0200 )edit

Hi, I just changed operator in Finland and mobile data stopped working and was grayed out like described. I removed all sim configuration directories like described in the other answer but it only started working after changing /var/lib/ofono/ril to point the new configuration directory. Thanks for sharing this!

TK009 ( 2017-03-28 14:03:28 +0200 )edit
4

answered 2014-07-18 18:00:00 +0200

SaimenSays gravatar image

updated 2014-07-18 18:01:24 +0200

For me it gets disabeld as jolla tries to connect to 4G, which is not supported for my provider. So go to settings and set mobile data to prefer 3G.

My fault was to think that 7,2Mbit is LTE, but is only 3G HSDPA. After setting so my phone does not grey out mobile data for 2 weeks up tow now...

edit flag offensive delete publish link more

Comments

1

At me the same problem. I have updated 24 hours prior to 1.1.1.27Vaarainjärvi of 1.0.8.21Tahkalampi . Germany , Vodafone Smart S. After some time , the compound for mobile data turned off and the symbol for was no longer accessible. I did this preferred switched 4G to 3G preferred . Immediately after the connection has been restored and the symbol available again. Immediately after reset to 4G everything worked again . Let's see what the future brings . So there seems to be setting a problem with the 4G 3G.

rosapold ( 2014-12-23 23:20:50 +0200 )edit
2

answered 2014-09-19 16:41:09 +0200

jovirkku gravatar image

Configuration and details of mobile network and WLAN settings is explained in this support article of Jolla Customer Care: https://jolla.zendesk.com/hc/en-us/articles/202490128.

edit flag offensive delete publish link more
2

answered 2014-09-22 15:10:35 +0200

tkenakka gravatar image

To everyone, if you faced/face is issue, could you comment what country&operator (MCC & MNC for techies) you faced this problem, and if it happened when taking the device into use, after a SW update or something else? Pease mention also if you had been editing some config files via shell previously :) Thanks

edit flag offensive delete publish link more

Comments

POLAND/ORANGE it occurs after update 10.

tuniek ( 2014-12-23 17:49:56 +0200 )edit
1

Netherlands/Simyo (KPN network). It occurs since update 10

Martijn ( 2014-12-28 13:41:00 +0200 )edit

Same as Martijn above, the only config file I recall having edited is the hosts file in order to block advertising servers.

reinouts ( 2015-01-06 12:25:11 +0200 )edit

Sweden/Telenor. Mobile data gets greyed out (permanently, need reboot) when 4g is preferred. This happens when you disable mobile data or connect to WLAN. Running update 10. No edits done.

gusteng ( 2015-01-16 10:42:53 +0200 )edit

Germany/mobilcom-debitel (Vodafone network). I thought I was a techie but I don't know what MCC and MNC mean :-D if it's the access point names in the ofono config, they're web.vodafone.de and event.vodafone.de. I lose connection every other day or so. If I restart the network connections via Sailfish Utilities, it complains I need to reboot in order to reconnect my SIM — but I don't, waiting a couple of minutes actually fixes everything. Except every week or so I do have to reboot, otherwise nothing works anymore.

Oh, and all that started happening since the 1.1.1.27 update. My mobile data worked fine before that.

lalomartins ( 2015-01-20 13:41:15 +0200 )edit
1

answered 2017-05-23 23:59:20 +0200

In my case the root cause of the problem was the file /var/lib/ofono/ril.

The file contained a line with key DefaultDataSim: DefaultDataSim= The value for this key was the name of a subdirectory with the settings for a previous SIM card. Once I updated that value to the directory that was created for the new SIM card the mobile data icon became enabled (after restarting the ofono service as per the instructions in the answer from zlatko) I checked the file afterwards, and now the "DefaultDataSim" line has been removed, so it is possible that the file could have been deleted altogether.

Hope this can help someone else too :-)

edit flag offensive delete publish link more
0

answered 2014-07-18 13:07:30 +0200

cquence gravatar image

You could check your mobile network settings (APN), if they are not correct it might "disable" the Mobile Data icon.

edit flag offensive delete publish link more

Comments

How does one do that?

flywheel ( 2014-07-18 14:40:37 +0200 )edit

I don't remember exactly and I don't have my phone now to check. You need to do a long press on the network provider's name if I remember correctly. Also some help from this: https://together.jolla.com/question/3753/make-apn-settings-more-visible/

Open settings app -> tap "mobile network" -> long press on your providers name below "mobile data" -> tap "edit" on the menu that has opened.

cquence ( 2014-07-18 14:52:28 +0200 )edit

Thanks - found a way

flywheel ( 2014-07-18 16:25:01 +0200 )edit
0

answered 2014-10-06 10:51:24 +0200

tkenakka gravatar image

Thank you for your feedback (@muchasuerte, @zlatko et al), for your information.

There indeed is an issue on handling an empty Access Point Name parameter on Mobile Data settings. As you know, this is experienced by user as a dimmed "Internet" setting on Mobile Data settings UI which cannot be edited using a Long tap. According to Jolla an improvement for the specific issue has already been targeted for next future main Update (not included to https://together.jolla.com/question/50175/release-notes-software-version-10819-tahkalampi/). Disclaimer: schedules and content are subject to change, as usual :)

Notice: a missing "Internet" setting row on Mobile Data settings UI page should be a separate issue.

edit flag offensive delete publish link more
0

answered 2014-10-19 20:59:19 +0200

gupo gravatar image

Hi everyone, as I said here , I don't have such a file in my /ofono/ directory. Any idea ? :)

edit flag offensive delete publish link more

Comments

You mean in /var/lib/ofono/your_operator_number/ ? You have to go /var/lib/ofono/2082300... in your case. If there is no such file - try to create it. Below is how it looks like in my case for my operator:

[Settings]
Powered=true
RoamingAllowed=false

[context1]
Name=Internet
AccessPointName=inet-gprs.mtel.bg
Username=
Password=
Type=internet
Protocol=ip

[context2]
Name=MobilTel BG MMS
AccessPointName=mms-gprs.mtel.bg
Username=mtel
Password=mtel
Type=mms
Protocol=ip
MessageProxy=10.150.0.33:8080
MessageCenter=http://mmsc

Of course : first stop ofono.service, create file, start ofono. All is described above.

zlatko ( 2014-10-19 21:09:23 +0200 )edit

Again thanks so much zlatko. Good news, after reboot there is "gprs" in the second directory. How do I launch a text editor/file browser as root? The terminal says the file gprs is too narrow.

gupo ( 2014-10-19 21:14:29 +0200 )edit

I use 'vi' editor. You have to be root, then launch vi in terminal. Just type vi gprs when you are in the same directory where file is located. But you have to learn how to use vi. If you want to just see what is the file content type: cat grps

zlatko ( 2014-10-19 21:17:28 +0200 )edit

Thanks a lot, I'll work on that right now. Sorry for these "beginner's" questions ;)

gupo ( 2014-10-19 21:19:59 +0200 )edit

Well zlatko, you're my hero ! I just got back mobile data (4G). And also, I learned vi basics. I feel better now ;)

gupo ( 2014-10-19 21:36:14 +0200 )edit
Login/Signup to Answer

Question tools

Follow
17 followers

Stats

Asked: 2014-07-18 12:41:37 +0200

Seen: 17,313 times

Last updated: May 23