We have moved to a new Sailfish OS Forum. Please start new discussions there.
1

Text in menu (css?) & differences in menu

asked 2014-09-21 21:15:47 +0200

davekelly gravatar image

Hello Folks, first post here so bear with me as my terminology might not be 'correct'. . . . . .

basically there's some 'odd' text that appears in my menu, namely - !!sync_and_backup - exactly like that, it's been there in my phone menu since I got it just a couple of weeks ago and it also appears my menu is different from another users menu, even though we have the same OS version.

I'll include apic' here and the link below to my original thread on the jolla users forum if it helps.

Thanks in advance. dave

image description

http://forum.jollausers.com/jolla-phone/!!sync_and_backup-text-in-settings/

edit retag flag offensive close delete

1 Answer

Sort by » oldest newest most voted
0

answered 2014-09-21 21:41:43 +0200

nthn gravatar image

Probably a duplicate of this: https://together.jolla.com/question/54160/items-in-settings-are-lost/

There's a solution in there. (You will need to enable developer mode first.)

edit flag offensive delete publish link more

Comments

I'm trying to enable developer mode but I don't think it's working? At the side of developer mode it has SSU, I don't know exactly what that means in jolla terms, but if I press dev-mode then I get the dev-tools page, then enabling - and then nothing ? it goes back to dev-tools page - having just done it now, I was also prompted for a username and password so i used my jolla account details, not sure how to proceed from here ?

davekelly ( 2014-09-21 22:09:24 +0200 )edit

Edit: how do I run as root on Jolla? The first terminal command worked, the second prompted for for dev mode to be enabled, see above, or run as root, but I don't know how to do that without a root password.

davekelly ( 2014-09-21 22:12:09 +0200 )edit

In the developer tools settings, there should be an option 'Remote connection', enable that and you will be able to set a password for SSH and root. Then, in terminal, enter 'su', which will prompt you for the root password. Enter the password you just created (you won't see anything happening when typing it). Then you can use the version --dup command.

Once this is all done, you can disable developer mode again if you want to.

nthn ( 2014-09-21 22:31:47 +0200 )edit

(The 'SSU' thing is something for Jolla developers only, it won't do anything for users.)

nthn ( 2014-09-21 22:33:11 +0200 )edit
1

In Developer tools you tap Developer mode, you are shown the Developer terms, you accept them, and Developer mode is enabled. (It should be "lit up" now on the Developer tools page.) Don't touch "Allow developer updates" item under SSU.

Actually I think if you can see the Terminal app, you have Dev mode enabled.

You can set your root password in the Developer tools: Allow Remote connection and enter a password (or generate one). After that, you can use devel-su in Terminal to run commands as root. But I don't think version --dup should require root access.

Edit: Had some problem posting this comment, I see @nthn beat me to it in the mean time :)

ssahla ( 2014-09-21 22:37:44 +0200 )edit
Login/Signup to Answer

Question tools

Follow
1 follower

Stats

Asked: 2014-09-21 21:15:47 +0200

Seen: 213 times

Last updated: Sep 21 '14