Ask / Submit
4

Can't choose E-Mail identity (SMTP) for sending message via MS-Office365 [released]

asked 2015-01-25 15:23:00 +0300

groxxorg gravatar image

updated 2015-03-08 03:45:53 +0300

I've set up two different E-Mail-Accounts A and B, each of them with a different SMTP-Server for outgoing messages (also a different signature A an B). Account A is MS-Office365, account B a private provider. When composing a new message, it is only sent from identity B (including signature B) even while answering a message received at account A. There is also no chance to choose the right identity for A when composing a new message.

If someone discovers how to configure Jollas E-Mail Client correctly for MS-Office365, this would be nice to know :-)

Latest update on this: Problem is solved!


EDIT 0: PROGRESS Thinks I tried to resolve the poblem:

  • I checked the configuration by using ag-tool but can't find no suspicious entry.
  • Deleted and recreated the Account with Settings for IMAP and SMTP suggested by Microsoft Office 365: An error-message appears "Outgoing-Server needs Corrections". Still not working ...

EDIT 1: PROGRESS With a little help from Holger i was able to narrow this Problem down to a configuration problem with MS-Office365 SMTP-Server settings.

EDIT 2: EXPLANATION: VDVsx explained the background of this problem. The installation of MS-Exchange from Jolla Store was temporary a workaround.

EDIT 3: PROBLEM SOLVED: Fixed in 1.1.2 / Yliaavanlampi Thanks to all the developers, this problem seems to be solved :-)

edit retag flag offensive reopen delete

The question has been closed for the following reason "released in a software update" by VDVsx
close date 2015-03-03 14:33:38.088290

4 Answers

Sort by » oldest newest most voted
1

answered 2015-01-26 13:07:06 +0300

VDVsx gravatar image

Office365 SMTP server does not offer AUTH PLAIN, but instead offers deprecated AUTH LOGIN, and other authentications offered are not supported by Jolla email. I've added back the deprecated AUTH LOGIN as fallback for such situations, will come in next updates.

Please note that you are better off using exchange for these accounts, IMAP/SMTP for office365 has several issues, one really annoying is locking the account temporarily when more than 20 connections are made in a day, this can be easily reached if you have 2-3 devices using that account and they change IPs across networks[1], MS support forums are full of complains about the service and MS seems to not care much and advise to use exchange instead[2].

[1] http://community.office365.com/en-us/w/exchange/4185.throttling-limits-for-office-365.aspx

[2] http://community.office365.com/en-us/f/158/t/148254.aspx

edit flag offensive delete publish link more

Comments

Thanks VDVsx for your very helpful response!

Even if your answer does not solve the problem, I now understand the background of it. Thanks for that! Now i can sleep well again ;-) And by the way - your links now explain a problem of a friend of mine. IMHO Office365 is defective by design, not only for this issue.

Ps.: How to mark this request as 'answered'?

groxxorg ( 2015-01-26 19:05:41 +0300 )edit
1

answered 2015-03-03 14:33:24 +0300

VDVsx gravatar image

Fixed in 1.1.2 / Yliaavanlampi, AUTH LOGIN is now support office365 accounts should work fine over IMAP, if you still see any issues please comment here.

edit flag offensive delete publish link more

Comments

@VDVsx Right after i updated to latest release today, i was able to configure server-settings for IMAP and SMTP. Thanks to all the developers, this problem seems to be solved :-)

groxxorg ( 2015-03-03 17:34:29 +0300 )edit
0

answered 2015-01-25 16:30:32 +0300

Holger gravatar image

What does that mean: " there is no chance to choose the right identity" ? Did you find that switch for choosing the identity? It's by default hidden and can be made visible by tapping at the three dots at the right. Works fine here with 4 accounts.

edit flag offensive delete publish link more

Comments

I tried that; tapping at the three dots opens the possibility to add Cc or Bcc but no dialog for choosing another identity.

groxxorg ( 2015-01-25 16:38:07 +0300 )edit
1

So there is something wrong with that account? If you cannot find something obvious, probably remove it and create again from scratch?

Holger ( 2015-01-25 17:02:17 +0300 )edit

Thanks Holger for the quick response!

Meanwhile i also tried to delete an recreate the account. I found out MS Office 365 changed settings for IMAP and SMTP configurations (old once still working on all my other devices). So I changed the IMAP-server to outlook.office365.com (SSL Port 993) and SMTP-Server to smtp.office365.com (TLS Port 587) as suggested by Microsoft.

Still not working! A message appears "Settings for Outgoing-Server need to be corrected".

Since this seems to be a problem related to MS-Office 365 i changed the subjekt an tags of my report.

groxxorg ( 2015-01-25 17:18:30 +0300 )edit
1

I have 3 pop email accounts, 2 use different SMTP addresses.

As Holger says, tapping on the 3 dots should reveal (as well as Cc or Bcc), text that says; From..blahblah@blah.com - tap on that text. If there are other email accounts correctly installed, they should show here - they do on mine, no workaround or fix should be required (unless I misunderstand your question).

image description

Edz ( 2015-01-25 22:59:59 +0300 )edit

Thanks Markkyboy for your response!

This dialog I couldn't see (only Bc and Ccc) because of allegedly faulty entries in outgoing-server setup. I tried a setting like in my other devices (pod51xxx.outlook.com), but also a setting, as proposed by Microsoft (smtp.office365.com) and it didn't work.

After installing the MS-Exchange application from Jolla-Store, i was able to choose identities. I'm sure there must be a way to configure the SMTP-settings in the right way - who knows..

groxxorg ( 2015-01-25 23:24:11 +0300 )edit
0

answered 2015-01-26 11:35:39 +0300

c.la gravatar image

I believe this is a duplicate of this

https://together.jolla.com/question/1034/enhancement-identities-in-e-mail-client/

edit flag offensive delete publish link more

Comments

Nope - sorry c.la, it is not.

groxxorg ( 2015-01-26 18:54:26 +0300 )edit

Question tools

Follow
2 followers

Stats

Asked: 2015-01-25 15:23:00 +0300

Seen: 706 times

Last updated: Mar 08 '15