Ask / Submit
10

Mobile Data not working after switching SIM card

asked 2016-10-31 18:50:11 +0300

Denis gravatar image

updated 2016-10-31 18:50:44 +0300

Hello,

I stayed a couple of months abroad where I used a local SIM card. It worked, data was available. I also performed system upgrades on my phone during my stay. My system is now SailfishOS 2.0.4.14 (Fiskarsinjoki).

But back in my home country, I put back my home SIM card in the phone and could not use any more mobile data, even phone's configuration was correct. I tried to reset my mobile data configuration (as explained here: https://jolla.zendesk.com/hc/en-us/articles/202505018#22) and reboot the phone but it did not work.

As I finally found out how to solve it, here is the workaround, awaiting for a real bug fix.

  1. Stop Ofono service by typing systemctl stop ofono.service in a console
  2. Go to the folder /var/lib/ofono/ and list its content. You will have two sub-folders for each SIM card you inserted in your phone, and other files. Folders names are a numeric sequence. In my phone, it looks like "206...86", "206...86-3", "310...50", 310...50-3", "525...15" and "525...15-3".
  3. Identify to which operator which folder is linked. Check the file gprs in each folder not ending by -3 to find useful information.
  4. Edit the file /var/lib/ofono/ril. Its content will look like this:
    [Settings]
    DefaultDataSim=206...86

    Just replace the numeric sequence after DefaultDataSim by the one corresponding to your current SIM card (identified at step 3).
  5. Restart ofono with the command systemctl start ofono.service
  6. It should work now...

I suspect that this bug is linked to the multi SIM support for Jolla C, as having a default SIM for data is useful if your phone has several SIMs inserted in it at the same time but not so much if you can only have one SIM card in it at the same time...

edit retag flag offensive close delete

Comments

1

I can confirm this issue and workaround, having discovered the same method myself last night. It's a regression from 2.0.2, where hitting the 'Connect to Internet' action (followed by selecting the mobile data option) would allow new SIMs to be used.

I wonder if it's some side-effect of 2.0.4's change to jolla-settings-networking ('Set default data sim to "auto" for single SIM phone.').

stuart ( 2016-11-01 14:45:10 +0300 )edit

I had the same problem 3 months ago on Jolla1 and posted it here with workaround: https://together.jolla.com/question/141693/cant-connect-to-internet-after-using-sim-card-from-t-mobile/
This is old bug ;)

Schturman ( 2016-11-01 19:47:29 +0300 )edit

Thanks! I changed operator and the phone could not get any data.connection, even APN was supposed to be fine. Found that in ril file the old sim was listed as default sim. Changed the number to match the new folder number and magic happened! Had to use tinyedit started with rights. Now it works!

mj ( 2017-02-22 23:43:36 +0300 )edit

Is it the Treminal I need to use to change that number? How? Thank you

hwicha ( 2017-02-28 11:41:28 +0300 )edit

2 Answers

Sort by » oldest newest most voted
4

answered 2016-11-01 09:20:37 +0300

paulvt gravatar image

This is related to and/or a duplicate of: https://together.jolla.com/question/148246/bug-new-sim-crazy-behavior/ and https://together.jolla.com/question/147137/not-able-to-turn-my-mobile-network-connection-on/

I backed up my old ofono folder and the only difference I could basically find was with the DefaultDataSim setting which was still set to my old, no longer working SIM. Thanks for confirming this.

edit flag offensive delete publish link more

Comments

1

You are right, thanks for the additionnal information! I hadn't found those topics before posting, sorry (maybe I did not use the right keywords?).

Denis ( 2016-11-01 14:23:31 +0300 )edit
1

No problem! This issue could use more visibility. People don't often switch SIM, but I've been seeing this problem popping up every now and then.. here on TJC, on the IRC, etc.

paulvt ( 2016-11-01 14:47:17 +0300 )edit
0

answered 2017-06-16 18:56:52 +0300

slava gravatar image

There's also Ofono Logger app in the Jolla store which can fix that problem too. If you are having this issue, you should have "Fix mobile data" item in the pulley menu, select it and it will do this DefaultDataSim thing for you. The root cause of the problem should be resolved by one of the OS upgrades, don't remember exactly which one.

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
3 followers

Stats

Asked: 2016-10-31 18:50:11 +0300

Seen: 541 times

Last updated: Jun 16