We have moved to a new Sailfish OS Forum. Please start new discussions there.

[Wiki] GeminiPDA with sailfish os community port and sailfishX

asked 2018-06-24 18:27:20 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

updated 2020-06-19 21:36:38 +0200

gabs5807 gravatar image

Since 22th of June 2018 there is an 'official' flash image of a sailfish os community port at Planet Computers support page.

Edit 2020-06-19
Late, but some addidtional information for the version. It seems that there are some updates at this version, but no additional features or bug fixes (see Edit 2019-11-24). There is also no /home encryption for the Gemini PDA available (see question Why is there no /home encryption on GeminiPDA SailfishX?).
End Edit 2020-06-19

Edit 2019-11-24
This will probable be my last edit in this wiki. We have Sailfish 3 version for a while. Updating to new versions is easy with it. But I cannot see any progress. We still have no alien dalvik for the device, Jolla promised for 'Final phase'. I do not believe we will get it in future. But may be Jolla knows more secrets about it. And other features are still missing or buggy, here a partial list (answer calls with gemini is closed, switch microphone, screen orientation, apps orientation, battery drain with wifi, alarm not working). The device is good enough for playing around with sailfish only, but far from be a daily driver since 1.5 years.
End edit 2019-11-24

Edit 2019-08-23
Jolla's SailfishOS releases 3.0.3 and 3.1.0 brought only minor enhancements for the Gemini PDA.
This is in line with Jolla still defining these releases as betas for the Gemini (and hence still charges only € 30,- for a license) and they lack "Android support". Jolla might base Gemini's "Android support" on that for the XA2s, but this seems to require a newer kernel to be used (than 3.18 as currently in SailfishOS; PlanetCom's recent Android images provide a kernel 4.4 for the Gemini).
Supposedly SailfishOS for the Gemini will come out of its beta phase, when these two feats are accomplished.
End edit 2019-08-23

Edit 2019-03-19
The official SailfishX for EA (early access) users is available. Look at release notes. You may subscribe at account.jolla.com to early access.
You can manually update the community port as well (at your own risk: ssu re; version --dup). But you will stay with the kernel of the community version.

Linux Sailfish 3.18.41 #1 SMP PREEMPT Mon Jan 14 06:59:39 UTC 2019 aarch64 aarch64 aarch64 GNU/Linux

Linux Sailfish 3.18.41 #1 SMP PREEMPT Tue Feb 12 23:08:05 UTC 2019 aarch64 aarch64 aarch64 GNU/Linux

You have to build and flash a boot image for the community port manualy if you want to use a new kernel.

ATM I do not know what the changes are; obviously the compile date. But it is still a 3.18.41 kernel like the community port.
End edit 2019-03-19

Edit 2019-02-28
You can buy an official SailfishX from Jollas shop. It comes with 'MS Exchange support', 'Software updates as long as device is supported' and 'Customer support as long as device is supported'. But there is

  • no Android 8.1 App Support
  • no Predictive text input
  • the capacity for rootfs is lower than 2.5GB, maybe cause later update problems

No other linux install option beside official SailfishX possible, because SailfishX uses the linux partition as lvm (logical volume manager) device. (As per description at 'Edit 2019-02-14')

Almost all known issues from the community version are still present. For me it is disappointing, waiting so long and getting not more than a community+ version.

But, maybe buying SailfishX will support the development in the future.
End Edit 2019-02-28

Edit 2019-02-14:
You can select sailfish os (community port in the old Partitioning Tool as 2nd or 3rd boot option. This community port is still usable. It is updateable if you have done the modifications listed below at 'Edit 2018-11-19'.

More Information on Planet Computers support page.

There is a new version available. It needs new flashing. If you want to stay with the community port which is integrated into the linux partition with debian beside it, you should not install the new version.

New since 12th February 2019: A 'community like' SFOS beta (looks like a pre-official version, without EAS, without XT9 and without AlienDalvik) is available. Select it with Partitioning Tool. It is possible to use it as 1st boot option. You can select 0GB for Android, if do not want to use Android / LineageOS.
Tip: If you want to use Android or rooted Android / LineageOS beside SFOS, select Android for 1st boot option. Why? Because updating process and rooting tools like Magisk do not know about boot2 and boot3 and always modify the boot image in boot (1st boot). That will kill your sfos boot image if it is in the 1st boot.

Flashing is easy following instructions from Planet Computers support page Linux_Flasing_Guide. SailfishOS is using the linux partition for itself, there is no more room for linux (debian or kali), because SailfishOS uses lvm (logical volume manager) and the debian or kali do not use lvm.

Making SFOS fully usable after flashing is a bit tricky: The SFOS version flashed is called (for which no online repositories are available, see below) and is a version for cbeta users only.
The missing online repos are causing a couple of annoying symptoms: You cannot use the Jolla Store, you cannot enable developer mode, etc. (i.e., all actions, which need additional RPMs from Jolla's repositories).

But there is a light in every night (just make a jump to the left or set SSU to :-)):

  1. Start SFOS the first time
  2. Enable settings -> Untrusted software -> Allow untrusted software
  3. Download fingerterm latest (armv7hl) by lourens from openrepos.net, click on downloaded message, click on fingerterm in transfers and then on '+' to install it.
  4. Start fingerterm and execute an ssu re in there.
  5. Now that the version mismatch is temporarily resolved, creating or entering a Jolla account is possible, to make the Jolla Store usable.
  6. After logging in to the Jolla Store (seems to require EA rights for this account), enabling developer mode works.
  7. Become root user per devel-su and execute ssu re again (done as root it is able to set the correct release number permanently in ssu.ini), followed by a version --dup to ensure all installed RPMs are for (it might download and install a few RPMs).
  8. Reboot and execute a pkcon refresh (as root): You now have a fully working installation of SFOS


  • it is beta (most known bugs still there), nice list for is still valid (including: wlan eats the battery).
  • Many apps have orientation issues. Use Patchmanager3 with GeminiPDA- or other orientation Patches (e.g. "Allow all orientations" by coderus) to alleviate this.

End Edit 2019-02-14

Edit 2019-01-09: Ok, it is update time again -- but it is a little bit tricky and you need an account for the Jolla store to do it. Because the last community version is and the next version is EA (early access) from Jolla. It is beta and still under development. Read this step by step guide first and if you understand everything you may start. I did it this way and it works for me. Remember, if you are using patches, that there may be no version for, because it is not official. If you need your patches do not update. As before every update disable all patches before you start.

If you have debian installed too, an optional backup of sailfishos is very easy before update: Start your debian and use terminal as root to makethe backup as tar archive.

tar --numeric-owner -C /.stowaways -czvf /YOURBACKUPFOLDER/sailfishos.tar.gz ./sailfishos

Lets do the change from community version to Jolla EA version (Device adaptation It is still like community, no aliendalvik, no eas, no xt9. You do it at your own risk just for fun. Start your sailfishos and make all as root in terminal.

1. disable your patches (settings-patchmanager) and disable openrepos repositories
  for i in $(ssu lr 2>&1 | grep openrepo | cut -d" "  -f3); do  ssu dr $i ; done

2. disable community adaptation repos
  ssu dr adaptation-community
  ssu dr adaptation-community-common

3. delete the files at /usr/share/ssu/features.d/
  rm -f /usr/share/ssu/features.d/adaptation-community-common.ini
  rm -f /usr/share/ssu/features.d/adaptation-community.ini

4. set releasemode an add repos
  ssu re
  ssu ar adaptation-0 https://store-repository.jolla.com/releases/
  ssu ar adaptation-1 https://store-repository.jolla.com/releases/
  version --dup

5. check repositories,
  ssu lr
 you should find under
 "Enabled repositories (global):"
 - adaptation0 ... https://store-repository.jolla.com/releases/
 - adaptation1 ... https://store-repository.jolla.com/releases/

 and if this repos are there, then delete the user repos adaptation-0 and adaptation-1 we created before
  ssu rr adaptation-0
  ssu rr adaptation-1

 the old adaptation-community and adaptation-community-common are still under disabled repos, if they are without url then delete them else they should stay disabled (you can do it with the following commands)
  ssu er adaptation-community
  ssu rr adaptation-community
  ssu dr adaptation-community
  ssu er adaptation-community-common
  ssu rr adaptation-community-common
  ssu dr adaptation-community-common

5. reboot

6. enable openrepos repositories
  for i in $(ssu lr 2>&1 | grep openrepo | cut -d" "  -f3); do  ssu er $i ; done

7. refresh package cache
  devel-su pkcon refresh

Check at "Settings->About product" the Device adaptation = done. If it is not something went wrong and you may have lost sensor functionality and more.

on error If something or everything wents wrong, its time to restore your backup. Start your debian and use terminal as root to make the restore from tar archive.

tar --numeric-owner -C /.stowaways -xzvf /YOURBACKUPFOLDER/sailfishos.tar.gz

Reboot to your Sailfishos community version.

End Edit 2019-01-09:

Edit 2018-06-30: Since 26th of June it is possible to set android space to 0 in the Partitioning Tool and use debian as boot1 and sailfishos as boot2 and boot3. You will get a 'LinuxOnly' scatter file. I flashed my x25 geminipda with the 'Gemini_x25_LinuxOnly.txt' and have a device without android now.

I read, that x27 users have to use android to select the SIM first, before sailfishos is working. Maybe 'LinuxOnly' is not working on x27. If you have a x27 and flashed a working 'LinuxOnly', please add it to this wiki or write a comment.

End Edit 2018-06-30:

Edit 2018-11-19: Community Port Version is ready to install (state is testing).


repos = adaptation-community
pattern = Feature community adaptation
description = Enable ssu for community ports

adaptation-community = http://repo.merproject.org/obs/nemo:/testing:/hw:/planet:/geminipda/sailfishos_%(release)/


repos = adaptation-community-common
pattern = Feature adaptation community common
description = Common packages needed by community's HW adaptation

adaptation-community-common = http://repo.merproject.org/obs/nemo:/testing:/hw:/common/sailfishos_%(release)/

start the update to

ssu re
pkcon refresh
version --dup

Maybe you have to disable openrepo repositories for update and revert some patches (i have installed non of the patches).

The system works as expected. But sometimes WLan did not work and i have to reboot. Also the landscape bug is not fixed (not on startup screen nor on settings). I think adapting it from the table version should be some kind easy (but i'm no a programming geek) ..

Terminal rotates most times fine on startup (may be the sensor calibration did not work always exactly).

Other hints show below on older versions.

End Edit 2018-11-19:

Problems with the community version:

  1. Permanent deauth and reauth of wifi starts if display turns off and eats my battery.
  2. Display standard is landscapeInverted. It turns to early to landscape and all is upside down.
  3. The geminipda should switch microphone and speaker if you turn it over on a call. With sailfishos it does not.
  4. More telephony quirks. You have to open it to answer a call or make one, and the silver button does nothing. It should be at least possible to answer an incoming with a closed clam shell.
  5. External speaker still on when headphones plugged in

Possible first steps after installing the community edition:

Warning: A lot of these things change your system. An Error might ruin your Installation. You have been warned.


As with every Sailfish OS system, you'll find most applications on openrepos.net. To make installing apps easy, the following steps will help:

  • In Settings, enter the "Untrusted Software" section and enable the installation. Read the warnings carefully.
  • Navigate to https://www.openrepos.net and search for "storeman". Find the most recent version and download it. Tapping on the "finished" notification will bring you to the list of downloads. Tap the .rpm file to install it.

Applications with added keyboard functionality for gemini pda

Webcat bb10 key shortcuts for the browser.

  • P - Previous,
  • N - Next,
  • K - Bookmarks,
  • Q - Tabs,
  • W - New Tab,
  • Shift+W - New Window,
  • T - Scroll to top,
  • B - Scroll to bottom,
  • A - Add to bookmarks,
  • L - Reload page.

Piepmatz key shortcuts for the Twitter client:

  • 1-6 - Tabs (Timeline, Notifications, ...)
  • [cursor up/dn] - Scroll tweet up/dn
  • t - Top
  • b - bottom
  • [cursor left] | ESC - back
  • N - New tweet
  • R - Refresh
  • S - Settings
  • A - About
  • [Enter] inside a tweet - Show thread

Special commands for gemini pda*

Turn wifi off

echo "0" > /dev/wmtWifi

if you done so you have to turn it on before you can use it again

echo "1" > /dev/wmtWifi

LED control

echo "<ledNo.> <red> <green> <blue>" > /proc/aw9120_operation

values: - ledNo. [1..6] - red: [01] - green [01] - blue [01] LEDs 1 to 6 have RGB, example

echo "1 1 0 0" > /proc/aw9120_operation # LED1 turns red
echo "1 0 1 0" > /proc/aw9120_operation # LED1 turns green
echo "1 0 0 1" > /proc/aw9120_operation # LED1 turns blue
echo "1 0 0 0" > /proc/aw9120_operation # LED1 turns off

you may combine colors by yourself setting RGB at the same time to 1.

LED7 is different and has only RBx as parameters you can set it to red, blue, violet and off.

echo "7 1 0 0" > /proc/aw9120_operation # LED7 turns red
echo "7 0 1 0" > /proc/aw9120_operation # LED7 turns blue
echo "7 1 1 0" > /proc/aw9120_operation # LED7 turns violet
echo "7 0 0 0" > /proc/aw9120_operation # LED7 turns off

Funzel uses gemini pda LEDs for visualisation of incoming calls.


If you know what you're doing, installing coderus' Patchmanager (from openrepos) enables you to change many facets of the system. If you kind of know what you're doing you can use premade patches to make your life easier:

  • Search for and install "Patchmanager 2" from coderus via the storeman application. Alternatively, you may try the beta of "Patchmanager 3", which uses a new method of changing files in memory instead of on the disk.

Landscape Mode

After boot, everything will be sideways until you turn the device a bit.

If you have installed 'patchmanger 3' and do not want to change some system files install 'Default allowed orientations patch' from 'elros34' using the patchmanger webcatalog.

Set the allowed orientation from terminal this way

dconf write /desktop/sailfish/silica/default_allowed_orientations 8

Everything is done after a restart of lipstick or reboot. You have not to edit the system files.

If you have not installed patchmanger 3 or like to change system files do this: As root (devel-su):

vi /usr/lib/qt5/qml/Sailfish/Silica/Page.qml

→ inside function _updatePageOrientation(), replace pageOrientation = desiredPageOrientation with pageOrientation = Orientation.LandscapeInverted

FingerTerm will be rotated weirdly, but you can use ToeTerm as an alternative. If you can not live without FingerTerm, more changes are needed (also as root):

vi /usr/share/fingerterm/Main.qml

→ inside Item { id: page …, replace property int orientation: forceOrientation ? forcedOrientation : Screen.orientation with property int orientation: forceOrientation ? forcedOrientation : 8

Micro SD card

to use a micro sd card, open the terminal and install the required package with pkcon install sd-utils (older SFOS, newer versions should have udisks2 installed per default instead) then reboot.

Updates (you can do it at your own risk)

The default image can be updated from OBS. The 'Problems with this early community version' described above will remain. Some x27 users told on telegram, that the 'wifi bug' is solved (read at update about my experience on a x25 device).

update to (state is testing):

  • new: usb stick automount via otg out of the box

as root:

vi /usr/share/ssu/features.d/adaptation-community-common.ini

change this line:

adaptation-community-common = http://repo.merproject.org/obs/nemo:/devel:/hw:/common/sailfish_latest_%(arch)/


adaptation-community-common = http://repo.merproject.org/obs/nemo:/testing:/hw:/common/sailfishos_%(release)/

If do not change from devel: (state: unstable) to testing: (state: testing) you get trouble with your sensorfw (sensors not working, only a software problem). Before next step you can verify that the change is done with:

ssu lr

start the update to

ssu re
pkcon refresh
version --dup

update done.

update to (state is unstable):

  • new: wifi bug fixed, on x25 network freeze after a while (read all before update)

as root:

vi /usr/share/ssu/features.d/adaptation-community-common.ini

change content to:

repos = adaptation-community-common
pattern = Feature adaptation community common
description = Common packages needed by community's HW adaptation

adaptation-community-common = http://repo.merproject.org/obs/nemo:/devel:/hw:/common/sailfish_latest_%(arch)/

Next vi /usr/share/ssu/features.d/adaptation-community.ini

change content to:

repos = adaptation-community
pattern = Feature community adaptation
description = Enable ssu for community ports

adaptation-community = http://repo.merproject.org/obs/nemo:/devel:/hw:/planet:/geminipda/sailfish_latest_%(arch)/

Before next step you can verify that the change is done with:

ssu lr

start the update to

ssu re
pkcon refresh
version --dup

Some x27 users told, that the 'permanent deauth reauth wifi bug' is fixed with the update. On my x25 early bird the bug is gone too, but after a while the network dies. Symptom: I cannot switch wifi on/off, cannot switch flight mode on/off and have to restart network or reboot.

Responsible is 'sailfish-connman-plugin-suspend-wmtwifi-0.0.2-1.3.1.jolla.armv7hl.rpm' that suspends the wifi. I decided to deinstall it.

devel-su pkcon remove sailfish-connman-plugin-suspend-wmtwifi

The 'permanent deauth reauth wifi bug' ist back, but the network is working all the time. To save battery life switch wifi off manualy before the display turns off.

update done.

Useful patches

'Launcher combined patches' – lets you customise, for example, the number of rows/colums in the application grid, which is really nice on the 2:1 aspect ratio. You may have to install the forked version from openrepos if you are on SFOS 2.1

'Default allowed orientations patch' – fix the orientation (look above at Landscape Mode)

edit retag flag offensive close delete



From the link: "... Sailfish OS Community edition..."

Is that a formal term (like versus "Enterprise Edition")? If so, what's the difference between the community edition and the version that I have running on my Jolla 1?

Éibhear ( 2018-06-25 11:56:56 +0200 )edit

typically it signifies lack of First Party support from Jolla, as well as lack of paid for proprietary things like alien-dalvik and exchange support

r0kk3rz ( 2018-06-25 12:14:34 +0200 )edit

Hello, i installed the devel SF3 (version on my Gemini PDA (as i wrote below).

Now i read at the Jolla blog that a beta version ( will be provide later this year.

Did this mean, that this beta version is the further development of community version on http://repo.merproject.org/obs/nemo:/devel:/hw:/planet:/geminipda/sailfish_latest_armv7hl/ (or on the testing tree)? Or is there an other project on Jolla or Gemini side?

The version works quite fine, but with some restrictions to the landscape mode. This should be corrected for the OS side at version (as i read).

But some apps seems not to use standard rotate mechanism (as i see on my tablet). I hope the developer of this apps also will correct this behaviour ;-).

gabs5807 ( 2018-11-10 11:47:07 +0200 )edit

Many thanks for the info. I updated to as described and it worked for me ;-).

gabs5807 ( 2019-01-12 14:38:08 +0200 )edit

Is it possible to set bootloader order: boot1 - Debian; boot2 - official SailfishX; boot3 - Android or nothing?

Or: boot1 - official SailfishX; boot2 - Debian; boot3 - Android or nothing?

orol ( 2019-02-28 14:51:27 +0200 )edit

8 Answers

Sort by » oldest newest most voted

answered 2018-06-30 11:54:21 +0200

Paul Tap gravatar image

Flashed it on my Gemini yesterday and it looks like this is the OS for this device. Didn't expect it as Sailfish is so touch oriented, but being able to do almost everything using gestures is a perfect combination with a keyboard is seems. I'm glad to be back on board having a good replacement for my Jolla1 and Jolla Tablet.

For now I think Android will stay my main OS as I need some of its apps and Alien Dalvik isn't available yet, but I do plan to run Sailfish as much as possible in order to test apps etc.

Two things I noticed. On the hardware side when running cat /proc/cpuinfo it only shows me 1 cpu/core. Same in top. The Sailfish browser is still not the speediest one around. Especially on a device where apps sometimes lack, having a speedy browser (for instance running Libreoffice via CODE on my Nextcloud server) is a must.

Nevermind. First impression is great!

edit flag offensive delete publish link more



Hi Paul!

I am very interested into the Gemini PDA! I have a couple of questions and hope that they will not take too much time:

What does the keyboard feel like? What is your experience with using it as a cell phone? Is it very heavy? Would you carry it around as your first device in a pocket?

Thanks in advance!

Cheers Dejan

ds1979 ( 2018-07-14 22:17:41 +0200 )edit

Hi Dejan,

the keyboard is great. Takes a bit time to get used to it and getting to know it, but that comparing it with a regular keyboard, not with anything on screen.

It's not a lightweight phone, but for me it is ok. I use it a lot with a bluetooth headset and my asteroidos watch, but holding it to your ear, even for long periods (>30min.) is no problem at all.

For me it already has become my primary device. Hardly touch any of my other device anymore (I do have plenty), so I think that describes it best.



Paul Tap ( 2018-07-15 18:04:01 +0200 )edit

answered 2018-09-25 22:53:34 +0200

depscribe gravatar image

I've been using SFOS (the Planet-supplied community version) as my daily driver for more than a month now, and while there are a few little telephony quirks -- have to open it to answer a call or make one, and the silver button does nothing -- it's been more than satisfactory. Even have been running the free-download Microsoft Word 6.0 for DOS in the modified-for-SFOS-on-Gemini version of dosbox, and it's more than adequate (just remember to save in .rtf instead of .doc, because nothing current can read the file, otherwise). I can't imagine how anyone could use anything but SFOS on the Gemini.

edit flag offensive delete publish link more



thanks for the nice dosbox hint. I added telephony quirks to the list of problems.

jolladiho ( 2018-09-26 15:14:11 +0200 )edit

The Gemini-optimized dosbox is here: https://www.oesf.org/forum/index.php?showtopic=35467 -- you want to go to page two, where the link is for d/ling Dosbox_0.3_1.armv7hl.rpm.gz. It's right after the screenshot of running Windows 3.1.1 in a dosbox window on a Gemini under SFOS!

It was developed particularly for those who would play old DOS-based games, and particularly remarkable is the excellent mouse support.

depscribe ( 2018-09-26 20:19:24 +0200 )edit

Sounds really odd having a dosbox version of word running ... gg

I guess I will see it for myself running some times.

megalith ( 2018-12-02 01:25:12 +0200 )edit

answered 2018-11-02 19:46:28 +0200

depscribe gravatar image

It is reported that an upgrade to SFOS 3 has been performed on Gemini. (I haven't tried it yet on mine.) The recipe is here: https://www.oesf.org/forum/index.php?showtopic=35597&st=0&gopid=290536&#entry290536

edit flag offensive delete publish link more


Update to (as described on the Web page) works as expected. The behavoir with the start screen is not fixed. But this is should also be on other SailfishOS phones and should be fixed on the generic sources. Changing the Page.qml is a work around, but have some ugly side effects.

  1. The icons and text on the app screen is overlapping, so the icons on a lower row hides the text on the upper apps (seems to be a known Problem and should be fixed in the future).
  2. The new scroll down menu is to small. I think it should use the full landscape size and not only the small middle part of the screen.
  3. jolla store did not work (only in landscape mode, with unmodified Page.qml - 'my apps' is emty!).
  4. Settings: all sub menus show empty screens (seems the same problem as above with modified Page.qml).
  5. sdcard with two partitions (first fat32, second ext4) could not be mounted. This problem is new and did not occur on edit: problem vanish after a few reboots.

All this tools/apps did not rotate to landscape mode (unmodified Page.qml) when the device orientation changed. I think this behavour is on all other SailfishOS (jolla and community) phones the same, but not on tablet. The tests i've done on my Jolla Phone 1, Jolla Tablet and Fairphone2 where on version and on the pda on version

I updated an unmodified native installation today to and then to

Update: 2018-11-05

I found some other apps that wouldn't rotate, probably this apps are not adapted to landscape mode and did also not rotate on the other phones to.

FingerTerm (and all other apps i used) worked out of the box on this versions, with some limitations (see above) .

May be it is usefull to setup a wiki with apps that work/rotate on phone, pda and tablet.

gabs5807 ( 2018-11-03 23:04:28 +0200 )edit

I've had a lot of luck with the release now that I've modified the Page.qml

As @gabs5807 mentioned, the Page.qml changes gave me empty sub menus in all settings, Store, etc. After some experimentation I got the sub menus back with the following Page.qml:


Everything seems to function correctly in landscape now. Overall I'm finding UI in the 3.0 release to be a much smoother experience. Gestures seem more responsive with less screen travel required, although some actions are still cut off at the bottom of the screen (such as closing an app on the homescreen)

stellarsquall ( 2018-12-11 06:49:21 +0200 )edit

answered 2019-02-15 11:33:46 +0200

pcfe gravatar image

updated 2019-02-15 13:11:05 +0200

Note on dev mode enabling; I also found myself in the position where dev mode could not be enabled after doing the following steps

  1. Use new partitioning tool from Planet Computers (downloaded files on 2019-02-14)
  2. only flash SFOS (no TWRP, no Android, no Debian, no Kali)
  3. boot freshly flashed Gemini
  4. try to enable developer mode
  5. progress bar about preparation shown for quite a while, then it drops back to previous screen and dev mode is still disabled.

At that point I got quite desperate as devel-su was not possible for me. (binary was not installed)

Turns out I had disabled dev mode access a while ago at https://account.jolla.com/ Enabled that, did ssu re (that works without devel-su), waited a bit (presume repos were refreshed), rebooted. Then I could enable dev mode and install the Jolla apps (Calendar, notes, etc)

I'll reflash again, skipping the ssu re step and see if that is sufficient before editing the wiki above.

EDIT: setting was indeed necessary.

edit flag offensive delete publish link more


you should do a version --dup after setting device to release mode

jolladiho ( 2019-02-17 15:41:23 +0200 )edit

I needed dev mode to be able to do devel-su version --dup. To be able to enable dev mode the ssu re was necessary.

pcfe ( 2019-02-19 12:42:51 +0200 )edit

answered 2018-09-27 00:17:47 +0200

kaulian gravatar image

About call without open device It's seems be a hack here
http://www.oesf.org/forum/index.php?showtopic=35520 Hope link is good because copy/paste don't work with browser ....

edit flag offensive delete publish link more



I'm the author of this hack and it works for me. I'm still planning to create a better solution.

yorambh ( 2018-09-27 00:27:55 +0200 )edit

answered 2019-07-30 13:46:23 +0200

nephros gravatar image

Anyone try an upgrade from to the current How did it go?

edit flag offensive delete publish link more



no problem if you have SailfishX installed. Try 'Settings -> Sailfish OS Updates'.

jolladiho ( 2019-07-31 18:04:29 +0200 )edit

I have been studying your entries all the way through. But I have no a clear idea about this. Gainesville Tree Pro Kensington

casseverhart13 ( 2019-11-28 04:08:42 +0200 )edit

answered 2018-09-11 14:40:26 +0200

Dankoozy gravatar image

Just ordered one :) can't wait for it to arrive and start installing Sailfish

edit flag offensive delete publish link more

answered 2018-10-19 22:00:18 +0200

CWL gravatar image

Hi. I followed your guide to change the adaptation-community-common.ini as root for update to However, when I run ssu lr, same devel repo url showed, nothing changed. Any idea how to get the global repo updated? Thanks.

edit flag offensive delete publish link more


how does the file "/usr/share/ssu/features.d/adaptation-community-common.ini" looks like?

cat /usr/share/ssu/features.d/adaptation-community-common.ini
jolladiho ( 2018-10-27 20:34:44 +0200 )edit

[adaptation-community-common] repos = adaptation-community-common pattern = Feature adaptation community common description = Common packages needed by community's HW adaptation

    adaptation-community-common = http://repo.merproject.org/obs/nemo:/devel:/hw:/common/sailfish_latest_%(arch)/

What I am trying to say is that even if I change the devel to testing, when I run ssu lr, it still shows devel.

CWL ( 2018-11-03 22:26:49 +0200 )edit

did you do anything special in order to install jolla-repo adaptation layer packages instead of community ones ? on my device it seems to retain the community ones

yorambh ( 2019-01-13 23:12:35 +0200 )edit
Login/Signup to Answer

Question tools



Asked: 2018-06-24 18:27:20 +0200

Seen: 9,185 times

Last updated: Jun 19 '20