How to correct tagging of mp3 files

asked 2014-01-24 15:27:52 +0200

Bimberle gravatar image

updated 2017-11-22 15:05:34 +0200

jiit gravatar image

Has anybody figured out how to tag mp3s so the media app displays them correctly?`That includes covers! I'm not sure wether 'media' is just buggy or wether it's a problem with the tagging. I've tagged all my mp3s to display correctly in MusicBee using the wonderful MP3Tag. Yet, some albums are displayed correctly, some aren't. The problem may be that there are several different kinds of ID3-tags, 5 different versions to be exact. Sometimes there are several versions in one file, maybe that's cause of the conflict?(Though it's supposed to only display the newest version in theory, some programs don't however) And as said, the covers: Do they need to be in a folders.jpg or embedded... or something else?

Thanks for the help, I'm gonna change the thread to a proper howto once we have all the answers.

edit retag flag offensive close delete


This seems to be a general problem with audio files, not only MP3. See

ossi1967 ( 2014-01-24 17:00:50 +0200 )edit

yes, if you have artwork tagged into mp3 tracks, they are shown. flacs don't. tried folder.jpg w/ flacs also didnt work

t0mps0 ( 2014-01-24 17:45:24 +0200 )edit

I have a huge collection of mp3-music files tagged with ID3-tags, and would also like to know is there any special preparation needed for them to be playable in Jolla Media player with all the metadata and covers visble and correctly when identified. Thanjs for this How-to/question ;)

foss4ever ( 2014-01-24 20:42:57 +0200 )edit

Sometimes covers won't show when copied to Music folder, but in terminal "tracker-control -e" and then "tracker-control -s" helped to show covers in media player.

kaari ( 2014-01-24 22:01:51 +0200 )edit

@kaari and the meaning of those command-line options -e and -s are? Starting and stopping tracker-control or reloading it's internal db..?

foss4ever ( 2014-01-24 22:26:21 +0200 )edit