We have moved to a new Sailfish OS Forum. Please start new discussions there.

Bug: problem with birthdays in calendar

asked 2013-12-27 00:53:59 +0300

Aad 't Hart gravatar image

updated 2014-01-14 16:38:29 +0300

chemist gravatar image

All birthdays are wrong in the calendar. They start at 23:00 on day 1 and last until 23:00 the next day.

My guess is this is a result of a timezone problem. The story is as follows: I travel around, bought the phone in Finland and linked my Google account. All contacts imported and correctly showing in the calendar. Now I arrived home in The Netherlands (1 hour earlier than Finland) and the phone correctly adjusted the timezone and time, but all birthdays are wrong. This is not correct!

edit retag flag offensive close delete


It's a nug if you ask me, but maybe you can import your contact again while you are in you're timezone so you won't have the problem.

BonoNL ( 2013-12-30 16:26:42 +0300 )edit

I also have this issue. All the birthdays are spread within two days.

w32blaster ( 2013-12-31 10:19:16 +0300 )edit

Rebooting the phone after the latest update resolved the problem. Now all birthdays are ok

Aad 't Hart ( 2013-12-31 10:23:28 +0300 )edit

Similar problems here. birthdays start/end 02:00 (GMT vs. EET) Seems some sync somewhere did not go quite right.

My Jolla calendars/contacts originate from a unholy sync combination of Exchange/Gmail/PCSuite/N9/vCard/etc. No surprise there might be some problems.

JarnoF ( 2013-12-31 10:52:13 +0300 )edit

From my point of view the birthday events should have a special frmat of "whole day event" which will not care of the start and end time but the date only (so it will be effectively not influenced by timezone changes).

Also there should be a customizable time for the reminder so that it is not ringing at midnight :)

strnous ( 2013-12-31 12:26:50 +0300 )edit

2 Answers

Sort by » oldest newest most voted

answered 2014-01-14 16:42:08 +0300

chemist gravatar image

As birthday entries are aggregated from contacts this should not be a problem to fix - change in time-zone and or time should generate a new birthday-calendar each time or the calendar needs to support different kind of entries to not have all-day events in general not show up as two days as soon as time or time-zone changes.

edit flag offensive delete publish link more


The best option would probably be if there were two sets of "All day" events:
- bound-to-date (no time delimiter; probably limited to birthdays, anniversaries, etc.), and
- starts 00:00, ends 00:00 the day after, shows up / is selectable in calendar as "All day", but still has start and end times (in case the Jolla owner swaps timezones, but still wants to use "home time zone" times for already added events).

phle ( 2014-01-14 17:26:39 +0300 )edit

answered 2014-02-01 00:01:37 +0300

JS gravatar image

updated 2014-02-01 07:50:13 +0300

I just get rid of this bug, I went to settings/accounts and removed my google account.

edit: unchecked the time setting automatic update, chosed Sweden (where I live)

Set automatic update to active and then I added the google account again. Now all the birthays in the calendar are whole day activities =)

Note: Before I've did this I updated to

edit flag offensive delete publish link more


Hm. Tried this.
First, it didn't work, but after having removed both my Google-account and my Facebook-account from
Settings → Account
and then re-added them, birthdays are now "from [birthdate 00:00] to [day after birthdate 00:00]". :-)
Thank you for your find!

(I still consider this a bug, though - I mean: Why did my non-Automatic location go back to Helsinki, Finland?
I did not have the Location activated (if that may be the cause), but I did have Automatic location activated.)

phle ( 2014-02-01 00:52:21 +0300 )edit

This is not a general solution as this bug is present for local contacts as well.

juergbi ( 2014-02-01 00:59:29 +0300 )edit

@juergbi - Sort of suspected something like that. :-(

(I've avoided adding local contacts and/or editing synchronized contacts (i.e. still having all phone numbers as "Home") so far, and am waiting for a future sync-in-both-directions.)

phle ( 2014-02-01 01:12:18 +0300 )edit

All my contacts except one is syncronized from google but as far as I saw, the syncronized contacts I've edited in the device wasn't deleted when I removed the google account from the device.

JS ( 2014-02-01 11:24:27 +0300 )edit
Login/Signup to Answer

Question tools



Asked: 2013-12-27 00:53:59 +0300

Seen: 1,260 times

Last updated: Feb 01 '14