Ask / Submit
45

Media no longer recognising album info after update 1.0.8.19

asked 2014-07-16 12:22:38 +0300

lxsbs gravatar image

Hi,

Since updating to 1.0.8.19, Media is no longer recognising the album and artist info of the music stored on my SD card. Originally it was only a few albums but it now seems to be all of them. I've deleted the app and reinstalled it with no luck.

I've installed QuasarMX player since this happened and it's finding all the associated info including the album art.

Is anyone else having a similar problem?

Thanks

edit retag flag offensive close delete

Comments

6

Yes, I have the same issue. Reinserting the SD card does not help. I see some songs in "All songs" view but they are zero length and the artist is unknown. The music files are just fine and not corrupted in the sd card. Re-creating tracker index with "tracker-control -r" does not help.

Update: It seems that the miners are not running properly. I saw some of the songs (not all) seen in the media lists by doing hard reset "tracker-control -r" followed by "tracker-control -s". Also needed to execute "tracker-control -s" many times for some weird reason. Decided to dump the native player and go to QuasarMX, at least it is working ok.

jr ( 2014-07-16 12:55:03 +0300 )edit
5

Yes I can confirm this bug, added FLAC files not seen by media player altbougb clearly there. All properly tagged.

unruly ( 2014-07-18 22:13:23 +0300 )edit

I'm also experiencing this issue.

I've had the Jolla for 2 days now, I updated to 1.0.8.19 the moment I unboxed it. I've since been happily listening to music from the SD Card via the Media App without issues; all artists, albums and songs correctly organised.

Today was the Jolla's first reboot (I ran the battery to 0%). Since powering it back up, the Media App just shows "All songs", "Albums" and "Artists". All the media seems to be there, and it's playable, but it's in one long list of songs under "Unknown Artist" with no other meta data and song durations of 0:00.

I've rebooted numerous times, removed and reinserted the SD Card and reinstalled the Media app but the problem still exists.

boxel ( 2014-07-25 23:27:06 +0300 )edit
2

Also have this issue... and just when i though the Media player was actually getting better. Trying all the solutions below but to no avail so far. It will now go back in the draw awaiting a few more updates till it becomes usable.

bockersjv ( 2014-07-31 11:58:18 +0300 )edit

I have that issue too. Hey, guys. Did y'all try to cut all the songs from your SD card to computer while your jolla is connected to computer? Then you unplugged it. After a while, you connected your jolla and then put all the songs back to your jolla. After a few day, my jolla still recognizes all the songs I put.

But Here's the problem I find: Say for example, I put some Songs of an artist which is from unknown album. When I clicked into that artist's album, it shows "unknown album". Then I clicked into it and see all the songs from Unknown album... I think it's a bug...

fenditsim ( 2014-08-04 12:40:31 +0300 )edit

4 Answers

Sort by » oldest newest most voted
7

answered 2014-10-03 18:03:01 +0300

Feffe gravatar image

updated 2014-10-04 09:34:09 +0300

I noticed as well as the artwork was not updated, but when I added new files I noticed that they were not added and automatically, so I dug a bit more. When I run tracker-control -es to reindex my files I suddenly lost most of my music, and what was left of my 42GB/~3500 music files was just a handful seemingly random songs some with and some without metadata. Basically the problem got worse.

Turns out the tracker-extract miner crashes at some point since I found this in the journal:

Oct 03 16:33:48 Jolla dbus-daemon[913]: [flac @ 0x460905c0] max_analyze_duration reached
Oct 03 16:33:48 Jolla kernel: tracker-extract: unhandled page fault (11) at 0x00000014, code 0x017
Oct 03 16:33:48 Jolla kernel: pgd = c2d80000
Oct 03 16:33:48 Jolla kernel: slim reconfig done!
Oct 03 16:33:48 Jolla kernel: [00000014] *pgd=b1e55831
Oct 03 16:33:48 Jolla kernel: , *pte=00000000, *ppte=00000000
Oct 03 16:33:48 Jolla kernel: Oct 03 16:33:48 Jolla kernel: Pid: 13326, comm:      tracker-extract
Oct 03 16:33:48 Jolla kernel: CPU: 1    Tainted: P        W  O  (3.4.91.20140612.1 #1)
Oct 03 16:33:48 Jolla kernel: PC is at 0x401b3c50
Oct 03 16:33:48 Jolla kernel: LR is at 0x4c988c90
Oct 03 16:33:48 Jolla kernel: pc : [<401b3c50>]    lr : [<4c988c90>]    psr: 800e0010
                              sp : beed3028  ip : 4cb292b0  fp : 460905c0
Oct 03 16:33:48 Jolla kernel: r10: 460905c0  r9 : beed3238  r8 : 00000000
Oct 03 16:33:48 Jolla kernel: r7 : fffe7960  r6 : 460909c0  r5 : 00000400  r4 : 46099b60
Oct 03 16:33:48 Jolla kernel: r3 : 00000400  r2 : 00016000  r1 : 00000004  r0 : 00000000
Oct 03 16:33:48 Jolla kernel: Flags: Nzcv  IRQs on  FIQs on  Mode USER_32  ISA ARM  Segment user
Oct 03 16:33:48 Jolla kernel: Control: 10c5787d  Table: 82f8006a  DAC: 00000015
Oct 03 16:33:48 Jolla kernel: 
                              R7: 0xfffe78e0:
Oct 03 16:33:48 Jolla kernel: 78e0  ******** ******** ******** ******** ******** ******** ******** ********
Oct 03 16:33:48 Jolla kernel: 7900  ******** ******** ******** ******** ******** ******** ******** ********
Oct 03 16:33:48 Jolla kernel: 7920  ******** ******** ******** ******** ******** ******** ******** ********
Oct 03 16:33:48 Jolla kernel: 7940  ******** ******** ******** ******** ******** ******** ******** ********
Oct 03 16:33:48 Jolla kernel: 7960  ******** ******** ******** ******** ******** ******** ******** ********
Oct 03 16:33:48 Jolla kernel: 7980  ******** ******** ******** ******** ******** ******** ******** ********
Oct 03 16:33:48 Jolla kernel: 79a0  ******** ******** ******** ******** ******** ******** ******** ********
Oct 03 16:33:48 Jolla kernel: 79c0  ******** ******** ******** ******** ******** ******** ******** ********
Oct 03 16:33:48 Jolla kernel: [<c010cabc>] (unwind_backtrace+0x0/0x11c) from [<c0110b18>] (__do_user_fault+0x7c/0xc4)
Oct 03 16:33:48 Jolla kernel: [<c0110b18>] (__do_user_fault+0x7c/0xc4) from [<c08b6a68>] (do_page_fault+0x374/0x3c0)
Oct 03 16:33:48 Jolla kernel: [<c08b6a68>] (do_page_fault+0x374/0x3c0) from [<c01002d4>] (do_DataAbort+0x134/0x1a8)
Oct 03 16:33:48 Jolla kernel: [<c01002d4>] (do_DataAbort+0x134/0x1a8) from [<c08b52b4>] (__dabt_usr+0x34/0x40)
Oct 03 16:33:48 Jolla kernel: Exception stack(0xc3f11fb0 to 0xc3f11ff8)
Oct 03 16:33:48 Jolla kernel: 1fa0:                                     00000000 00000004 00016000 00000400
Oct 03 16:33:48 Jolla kernel: 1fc0: 46099b60 00000400 460909c0 fffe7960 00000000 beed3238 460905c0 460905c0
Oct 03 16:33:48 Jolla kernel: 1fe0: 4cb292b0 beed3028 4c988c90 401b3c50 800e0010 ffffffff
Oct 03 16:33:48 Jolla kernel: tracker-extract(13326) send signal 11 to tracker-extract(13326)
Oct 03 16:33:49 Jolla tracker-miner-fs[13298]: GLIB CRITICAL ** Tracker -   (Sparql buffer) Error in task 0 of the array-update: column 
nie:url is not unique (strerror of errno (not necessarily related): No such file or directory)
Oct 03 16:33:49 Jolla tracker-miner-fs[13298]: GLIB CRITICAL ** Tracker - Could not execute sparql: column nie:url is not unique (strerr
or of errno (not necessarily related): No such file or directory)
Oct 03 16:33:50 Jolla kernel: wlan: [855:E :PE ] __limProcessAddBAReq: 1425: ADDBAREQ NUMBUFF 40
</c08b52b4></c01002d4></c01002d4></c08b6a68></c08b6a68></c0110b18></c0110b18></c010cabc>

I tried to get a core dump (by setting ulimit -c unlimited) before executing tracker-control -es, but it didn't seem to work (or it put the dump somewhere I didn't find). Does anyone know if there is a way to get tracker-extract to log when it starts working on each file? I guess it would be a good start to check if it is a specific file it fails on... Any developer who wants help to debug this, let me know, it happens every time I try to run tracker-extract.

Edit:

Turns out it's not a specific file that causes this, but it may be certain types of files that cause the miner to randomly crash (and in one case, hung). I reformatted the SD card and rsynced over the entire music library again while monitoring the tracker activity and the pid of tracker-extract. It was hardly precise science, but I think I found some sort of link, because it crashed on:

  • FLAC-files created with libflac 1.3 (I also noticed this)
  • FLAC-files that later showed up in the library as "unknown artist" and "unknown album" even though they have FLAC-metadata

So it obviously has problem with certain flac files, but when I tried to only index each specific file one at a time it did not crash, so it doesn't happen every time. Also, I managed to completely avoid a crash by first moving the "bad" files a few at a time to the SD card, and then sync the rest of the library.

I did run into another problem as well tough: when syncing the library the last time tracker-extract simply stopped scanning. The pid was still alive, so it wasn't a crash, but it didn't process any new files. I used lsof and hoped to see which file on the sdcard it had open (and perhaps tried to process) but was surprised:

# lsof -p 11185 | grep /media/sdcard | wc -l
611

Turns out tracker-extract had lots of files open on the SD card. I ended up killing the process and starting it again (with tracker-control -s) and then it processed the rest of the files... But a few hours afterwards it still had ~200 files open on the SD card, so I think it doesn't close files correctly. I only noticed .flac and .m4v files in the list, but I can't say for sure if other files get stuck as well (it may be related to the filesize?)

I really hope a developer take a look at this.

edit flag offensive delete publish link more

Comments

I'm pretty sure I have exactly the same problem. Thank you for looking into this so thoroughly!

paulvt ( 2014-10-04 10:43:45 +0300 )edit
1

Thanks for this. I wonder if this is just for flac files with album art. All mine do, and they're all 'Unknown'.

Andy Branson ( 2014-11-27 00:56:35 +0300 )edit
5

answered 2014-08-02 20:00:09 +0300

Holger gravatar image

As stated by others, tracker-control -se fixed the problem for me, too.

edit flag offensive delete publish link more

Comments

1

I just tried tracker-control -se for the first time and it resolved my problems too.

boxel ( 2014-08-02 20:17:50 +0300 )edit

Thank you!! I solved this problem

carmenfdezb ( 2014-08-20 02:38:00 +0300 )edit

I've finally gone into developer mode and tried tracker-control -se. It worked for some of the songs, but after switching the phone off at night it returns to unknown again. Am I going to have to do tracker-control every time?

lxsbs ( 2014-08-29 20:05:06 +0300 )edit
1

answered 2014-07-16 14:22:23 +0300

sponka gravatar image

updated 2014-07-17 23:41:40 +0300

My problem is somewhat different -- I had no music on SD card before update and after update created directory + put some music into.

By some weird coincidence stock player lists 2 copy's of each song with different length. First one doesn't play, second one below is "true" music file.

Looks like this: https://db.tt/F5UvU1If

As with others, QuasarMX works.

Edit: tryed witt trackers, here's output:

[nemo@Jolla ~]$ tracker-control -r
Found 271 PIDs?
Found process ID 969 for 'tracker-extract'
  Killed process 969
Found process ID 970 for 'tracker-miner-fs'
  Killed process 970
Found process ID 973 for 'tracker-store'
  Killed process 973
Setting database locations
Checking database directories exist
Checking database version
Checking database files exist
Removing all database/storage files
  Removing first index file:'/home/nemo/.cache/tracker/first-index.txt'
  Removing last crawl file:'/home/nemo/.cache/tracker/last-crawl.txt'
  Removing database:'/home/nemo/.cache/tracker/meta.db'
  Removing db-version file:'/home/nemo/.cache/tracker/db-version.txt'
  Removing db-locale file:'/home/nemo/.cache/tracker/db-locale.txt'
[nemo@Jolla ~]$ tracker-control -s
Starting miners?

(tracker-control:30883): Tracker-CRITICAL **: Could not create proxy on the D-Bus session bus, Error calling StartServiceByName for org.freedesktop.Tracker1.Miner.Applications: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process /usr/libexec/tracker-miner-fs exited with status 1
  ? File System
  ? Extractor

(tracker-control:30883): Tracker-CRITICAL **: No D-Bus proxy found for miner 'org.freedesktop.Tracker1.Miner.Applications'
  ? Applications (perhaps a disabled plugin?)
[nemo@Jolla ~]$

EDIT: reformated SD card and removed all *m3u files -- player now correctly recognize all songs!

edit flag offensive delete publish link more

Comments

1

I've removed all *.m3u files on the card and the media player is still not recognising any songs.

I haven't yet tried reformatting the SD card - which filesystem did you use?

boxel ( 2014-07-29 00:49:44 +0300 )edit
1

I get the same error when starting the 'journal-control -s"

[root@juubanjolla nemo]# tracker-control -s
Starting miners?

(tracker-control:2183): Tracker-CRITICAL **: Could not create proxy on the D-Bus session bus, Error calling StartServiceByName for org.freedesktop.Tracker1.Miner.Applications: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process /usr/libexec/tracker-miner-fs exited with status 1
  ? File System
  ? Extractor

(tracker-control:2183): Tracker-CRITICAL **: No D-Bus proxy found for miner     'org.freedesktop.Tracker1.Miner.Applications'
  ? Applications (perhaps a disabled plugin?)
Juuba ( 2014-10-21 14:30:18 +0300 )edit

Same error as @Juuba here.

WhyNotHugo ( 2014-10-21 15:39:20 +0300 )edit
0

answered 2014-07-16 12:47:18 +0300

lunatix gravatar image

Hi, try to remove and replace your SDCard, works fine for me.

edit flag offensive delete publish link more

Comments

Thanks. I've tried reinserting the sd card with the app open, closed and phone switched off with no change.

lxsbs ( 2014-07-16 13:03:41 +0300 )edit

Strange... my problem looked exactly the same. I closed the app, remove the card, reinserted it, opened media and after 1 or 2 seconds everything was here. you can also try "tracker-control -se" but didn't work for me and for jr neither

lunatix ( 2014-07-16 13:14:27 +0300 )edit
2

I had no success reinserting the SD card or rebooting, but running "tracker-control -se" seems to have done the trick for me: the music (all MP3s on the SD card) now appears properly recognised.

flypig ( 2014-07-27 00:44:18 +0300 )edit
1

Same for me like flypig. Didn't try "tracker-control -se" yet. Hope the problem is solved in next update and add some features to Media. QuasarMx UI is way to busy for me and looks to much android.

Hans ( 2014-08-02 21:50:57 +0300 )edit
Login/Signup to Answer

Question tools

Follow
10 followers

Stats

Asked: 2014-07-16 12:22:38 +0300

Seen: 2,164 times

Last updated: Oct 04 '14