Ask / Submit
2

Arabic characters not shown in Email [released]

asked 2013-12-31 12:55:25 +0300

Bale gravatar image

updated 2014-01-15 22:33:22 +0300

I received an email with Arabic characters in the body, but they are displayed as squares.

edit retag flag offensive reopen delete

The question has been closed for the following reason "released in a software update" by VDVsx
close date 2014-06-09 20:44:22.089304

Comments

Is the email content HTML formatted or plaintext?

veskuh ( 2013-12-31 13:02:36 +0300 )edit

TBH I'm not sure about the original mail, but I forwarded it to myself as plain text and the problem persists.

Bale ( 2013-12-31 13:39:58 +0300 )edit
3

There is an issue with the font.

There is Droid sana Arabic already which is grouped with all the various droid sans fonts under one family "Droid Sans"

The problem is that silica components hardcode another font for their usage. I don't know how the font substitution works but if I install another font or edit the fontconfig configuration file to remove the font family assignment for droid sans Arabic then arabic shows fine.

I don't really know what the proper solution would be

MSameer ( 2014-01-01 04:54:09 +0300 )edit

@MSameer

Kindly, could you please explain to us what did you exactly modify? Or which font did you install on your device, and where did you place the file?

That would be really helpful and much appreciated.

mlwane ( 2014-01-01 18:39:08 +0300 )edit
2

I edited /usr/share/fontconfig/conf.avail/55-droid-sans.conf And commented out this part: <match target="scan"> <test name="family"> <string>Droid Sans Arabic</string> </test> <edit name="family"> <string>Droid Sans</string> </edit> <edit name="fullname"> <string>Droid Sans</string> </edit> <edit name="fontversion"> <int>5</int> </edit> </match>

OR: You can also copy any ttf font under /usr/share/fonts/ and run fc-cache -f I tried with Amiri font from http://www.amirifont.org/ but any ttf font should work

A reboot is required in all cases.

Also note that this is not the proper solution as I do not yet know what the proper solution is

MSameer ( 2014-01-02 20:40:37 +0300 )edit

2 Answers

Sort by » oldest newest most voted
2

answered 2014-06-09 20:43:59 +0300

VDVsx gravatar image

Fixed in 1.0.7.16, Saapunki, if you still have issues please comment here.

edit flag offensive delete publish link more
0

answered 2014-02-02 23:04:21 +0300

updated 2014-02-02 23:08:41 +0300

as was stated in comments above fonts are there, but they are not used. To do it just:

cp /usr/share/fontconfig/conf.avail/55-droid-s* /etc/fonts/conf.avail/

fc-cache -f (not sure about that one as we rebot anyway)

reboot

edit flag offensive delete publish link more

Question tools

Follow
3 followers

Stats

Asked: 2013-12-31 12:55:25 +0300

Seen: 503 times

Last updated: Jun 09 '14