Ask / Submit
15

Faulty roaming on german o2-de and o2-de+ network

asked 2015-05-19 09:36:58 +0300

lispy gravatar image

updated 2015-05-19 12:10:30 +0300

chemist gravatar image

Recently two major mobile networks merged and we as customer can now roam freely between the two. They are called o2-de and o2-de+. But roaming doesn't work properly for me and my wife. O2 told us to restart the phones and it would work fine, but more than not I can't get no data connection at all. Maybe o2-de+ network isn't working at all, but I'm not sure about, that. WIll do more testing. Right now I force it on o2-de. International roaming is activated.

Anyone can confirm? Ideas?

edit retag flag offensive close delete

Comments

I was told that it should work for me too (using "netzclub") but could not notice a "+" like they said in the sms. I tried international roaming too but it is national roaming so there might be a difference and national roaming is not available in SailfishOS right now?

xllndr ( 2015-05-19 10:04:02 +0300 )edit

Here in Bremen I only found a named E-Plus network not the new o2-de+ I found on other devices

I'll check it when I'm getting around ;)

imunar ( 2015-05-19 10:08:31 +0300 )edit
2

Strange - for me it works just as expected - my Jolla switches between o2-de and o2-de+ and the data connection also works just fine.

casanunda ( 2015-05-19 10:41:28 +0300 )edit

For me, o2-de+ insn't working. i can't even connect to it manually.

shfit ( 2015-05-19 10:46:27 +0300 )edit

@casanunda@shfit Would you mind letting us know where in germany you are? I am located in munich.

lispy ( 2015-05-19 10:49:07 +0300 )edit

2 Answers

Sort by » oldest newest most voted
8

answered 2015-06-12 13:19:59 +0300

MoritzJT gravatar image

updated 2015-06-12 13:23:16 +0300

The solution first suggested by https://together.jolla.com/users/3565/lechris/ along the comment section might be our saviour:

Jolla / Settings / System / Mobile Network / Mobile Data => longtap on the connection name => edit

Connection name should be "internet" not "pinternet.interkom.de"

I have no idea if this setting comes from Jolla or from the SIM. If it's provided by Jolla, this is an error and needs to be corrected!

"internet" is for folks on contract while "pinternet.interkom.de" is for prepaid users only!

I was abroad twice now, once in France/Spain on one trip and in UK on the other with my Nokia 808 and Jolla on a MultiSIM on one contract. For the 808 roaming worked fine, for the Jolla it did not.

Now what I noticed after o2 conjoined eplus into national roaming is that the o2de+ channel (eplus) was not working on my Jolla but worked fine on the 808 so I boiled it down to the access point settings.

On my 808 the AP connection name was just:

internet

while on Jolla

it was set to

pinternet.interkom.de

Changing this to

internet

got me roaming in London working and now even national roaming works fine here.

Cheers

edit flag offensive delete publish link more

Comments

1

Yes, that worked for me, too. Great comment. I read about the faulty APN but had no idea that it didn't mean the MMS option but another, well hidden, option behind the connection name. Once I realized where the menu was hidden, it worked flawlessly for my phone and the one of my wife. Thanks again for that very well written, constructive post.

lispy ( 2015-06-12 23:28:36 +0300 )edit
5

answered 2015-05-19 11:33:07 +0300

chemist gravatar image

updated 2015-05-19 12:42:08 +0300

EDIT: Quick search in O2 forums about o2+ issues, seems o2 did really mess it up - this is no Jolla specific issue though. For example, https://hilfe.o2online.de/thread/60222 no LTE no more... and other issues https://hilfe.o2online.de/community/o2-netz-hilfe/national-roaming

To sum it up, call O2 Care and report a network issue. That 2g and 4g are only available as w/o +is an implementation error. http://youcando.o2online.de/mehr-netz is a joke as E-Plus just changed to E-Plus+ for everything and that does not need any special handling on the customer's end. Find O2 Customers and pester the Hotline about it!

In short, set to auto, Jolla should work just fine if you let it handle everything automatically, it should work on all technologies and if not, O2 is probably to blame, not Jolla. (Jolla is only to blame that technology hopping freezes the modem what needs a reboot...)

The + (plus) networks are only roaming for O2 actually so and should be swapped automatically. The last week O2 and E-Plus had issues on both ends. O2 customers should be used to network outages as that happened a lot the last couple of years... it seems that O2 is messing it up again.

If this issue persists please contact O2-Care and report the issue.

edit flag offensive delete publish link more

Comments

1

actually my jolla is using "o2.de" and "o2.de+", which is the expected behaviour (according to o2). at least to my understanding :)

edit: and there is only a 3g "o2.de+" network, 2g and 4g are only available as "o2.de"

till ( 2015-05-19 11:36:49 +0300 )edit
1

Same for me - my jolla switches between the two, and from my understanding, that is expected behaviour (o2-de+ means I'm using EPlus network at that moment).

casanunda ( 2015-05-19 11:44:39 +0300 )edit

As said, contact O2! As the E-Plus side is all technologies E-Plus+ (currently on 4G) and the setup should not be classic roaming at all. Please be aware that there still be areas with broken or incomplete mergers till end of the month but besides that you should be good to go with + only. The + does not mean that you are using E-Plus, it means you are logged in to the national roaming network of O2+EPlus - but that roaming (just to point it out again) is not handled by devices it is on a higher system level so customers do not need to care. Or do you think I am roaming on a LTE network of O2 that did not exist 2 weeks ago but was E-Plus ever since?!

chemist ( 2015-05-19 12:00:51 +0300 )edit

Quick search in O2 forums about o2+ issues, seems o2 did really mess it up - this is no Jolla specific issue though. For example, https://hilfe.o2online.de/thread/60222 no LTE no more... and other issues https://hilfe.o2online.de/community/o2-netz-hilfe/national-roaming

To sum it up, call O2 Care and report a network issue. That 2g and 4g are only available as w/o + is an implementation error.

chemist ( 2015-05-19 12:09:24 +0300 )edit

quoting from http://www.o2online.de/hilfe/o2-netz/netz-faq/#id-11413642 (sorry, german only): "Ist LTE auch Teil des National Roamings? LTE ist aktuell nicht Teil des National Roamings."

unfortunatly I'm not able to find a good source except for http://youcando.o2online.de/mehr-netz but for o2 customers the "o2.de+" means that the phone is using e-plus 3g while "o2.de" means 2g/3g/4g o2

till ( 2015-05-19 12:16:34 +0300 )edit
Login/Signup to Answer

Question tools

Follow
6 followers

Stats

Asked: 2015-05-19 09:36:58 +0300

Seen: 3,115 times

Last updated: Jun 12 '15