Ask / Submit
0

How to enable blocked developer mode and fix wrong update notification

asked 2018-10-23 23:27:20 +0300

jsommer gravatar image

updated 2018-10-23 23:58:05 +0300

I have updated ny Intex Aqua Fish manually with the following commands in this summer:

devel-su
ssu re 2.2.1.18
version --dup
reboot

This did work fine until today. The phone shows an available update to version 2.1.4.14. I tried to fix this by activating the developer mode and connecting to the phone via ssh.

If I try to activate the developer mode in the developer settings a progress bar is shown until the developer settings are shown again with not activated developer mode.

I'm afraid I have to reset the phone to factory settings. Has someone an idea?

Update: With the help of this thread I could activate developer mode again. I have installed ShellEx and etnered

ssu re 2.2.1.18

If I enter ssu s, the terminal shows following output. I just removed my device I here:

Device registration status: not registered
Device model: Intex Aqua Fish (l500d / Aqua Fish)
Device UID: 
Release: 2.2.1.18
Domain: sales

I'm wondering, that the device is not registered, because I'm logged in with my jolla account.

What can I do next to fix the release issue?

edit retag flag offensive close delete

Comments

You should NOT enable "developer updated". ONLY enable "developer mode".

Nieldk ( 2018-10-24 09:53:44 +0300 )edit

Sure. I have never selected developer updates.

jsommer ( 2018-10-24 12:12:24 +0300 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2018-11-27 18:31:39 +0300

glv gravatar image

updated 2018-11-28 04:51:20 +0300

It's normal, Aquafish shows device status as 'not registered'. Below is my terminal o/p with UID masked:

[root@Sailfish nemo]# ssu s
Device registration status: not registered
Device model: Intex Aqua Fish (l500d / Aqua Fish)
Device UID: XXXXX
Release: 3.0.0.8
Domain: sales

Successfully updated to 3.0.0.8 from 2.1.4.14 without any issues.

EDIT: I overlooked the update issue mentioned in question, adding to @olf answer

Follow manual update as mentioned in zendesk and performing below steps before the reboot might be good and doesn't need any extra effort.

pkcon refresh
pkcon -v update

Extra:

In the cleanup part, while removing file you need to use '-f' flag

Additional links:

  1. Manual Update
  2. pkcon refresh/update
  3. Alternate to above pkcon process
  4. If the notification still persistent perform this process and select software update to manual
edit flag offensive delete publish link more
0

answered 2018-11-27 23:46:13 +0300

olf gravatar image

updated 2018-11-27 23:48:08 +0300

@jsommer,

What can I do next to fix the release issue?

  1. As @glv already denoted, "not registered" is the usual state (i.e. "normal").
  2. One should follow all steps Jolla advises for manually updating, including the section Final clean up.
    Most people seem to miss these steps, often (but not always) resulting in incorrect update notifications by the Jolla Store background process.
    Side note: After executing the Final clean up commands, it is advisable to issue (still as root) a pkcon refresh or if you have zypper installed, alternatively and more thoroughly pkill store-client && zypper clean && pkcon refresh followed by rebooting.
edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
2 followers

Stats

Asked: 2018-10-23 23:27:20 +0300

Seen: 492 times

Last updated: Nov 28 '18